PDA

View Full Version : [FIXED] Using checkbox selection model in the editable grid produces an error



Qtx
20 Jun 2011, 9:16 AM
REQUIRED INFORMATION


Ext version tested:

Ext 4.0.2


Browser versions tested against:

IE 9.0.8112.16421
FF 5, firebug 1.7.3
Opera 11.11
Chrome 12.0.742.100
Safari 5.0.5


Description:

If a grid is editable and has the checkbox selection model, then the following error occurs when selection the checkbox:

column.getEditor is not a function
editor = column.getEditor(record);
ext-all-debug.js (line 80534)


Steps to reproduce the problem:

Create an editable grid with the plugin

var cell_editing = Ext.create('Ext.grid.plugin.CellEditing', {
clicksToEdit: 1
});
Use Ext.selection.CheckboxModel as the selection model
Try to select a row by clicking the checkbox. The browser shows the error described above


The result that was expected:

The row should be selected.


The result that occurs instead:

The row is selected.
The browser shows javascript error described above.



HELPFUL INFORMATION


Debugging already done:

Apparently, by clicking on the checkbox, the checkbox column for selections is treated as an usual editable column, what is wrong.


Possible fix:

not provided


Additional CSS used:

only default ext-all.css


Operating System:

Windows 7

rvaibhav
23 Jun 2011, 6:29 AM
same here.
I also get the same error. Whenever I check uncheck the column , I get above mentioned error.

Qtx
24 Jun 2011, 10:39 PM
Formatted with the new bug report template

mitchellsimoens
26 Jun 2011, 9:22 AM
Formatted with the new bug report template

Awesome!!!! Thank you very much!!! Let me verify and see what's going on :)

mitchellsimoens
26 Jun 2011, 9:25 AM
Verified and reported!

rvaibhav
11 Jul 2011, 1:53 AM
Dev team any update on this particular issue?

mitchellsimoens
15 Nov 2011, 7:40 AM
I just tested against our latest code and the cell editing plugin is working with the checkbox selection model. However, I tried to select a row using the checkbox selection model with the row editing plugin and I get an error.

Qtx
15 Nov 2011, 8:03 AM
Yes, I pointed out exactly this error that occurs when selecting the checkbox for the selection of a row. Normal editing of a normal editable cell works well.

Felicitus
4 Jan 2012, 11:14 AM
A bugfix for ExtJS 4.0.7 can be found here:

https://github.com/partkeepr/PartKeepr/blob/master/src/frontend/js/ExtJS/Bugfixes/Ext.grid.plugin.CellEditing-EXTJSIV-3318.js