View Full Version : Deployment Error with Sensha SDK Tool - 'null' is not a constructor

15 Jul 2011, 6:55 AM
I'm trying to deploy my extJS-Application, which is written in MVC-Architecture style. As described in the extJS Docs (http://docs.sencha.com/ext-js/4-0/#/guide/getting_started) I've first tried to generate a JSB3 File with
sencha create jsb -a index.html -p app.jsb3 Sadly I've got the following error:
undefined:0 TypeError: 'null' is not a constructor

I'm working on MAC OS X with Sencha Command v1.2.2.

My application works fine in the debug-mode. I have so many files that I couldn't insert all my source code here .. but of corse if someone can give me his assumption where this error occurs I will paste that part of my application..

Thanks for any help!

15 Jul 2011, 8:29 AM
All right, I found the solution:
For me, it was not clear that I've created a "...applications built on top of a dynamic server-side language like PHP..." (see doc (http://docs.sencha.com/ext-js/4-0/#/guide/getting_started)).
Deploy my app this way
sencha create jsb -a http://localhost/path/to/my/local/index.html -p app.jsb3 as described in the extjs-docs, everything works fine now..

19 Jul 2011, 10:59 PM
Great to hear, thanks for the feedback. Sounds like we need to do a better job making this more obvious so I've logged a ticket to improve the docs here

29 Aug 2011, 12:35 AM
I'm facing with the same error message. Unfortunately I already use the URL pointing to my server, so I do everything according to the documentation.
Can someone please describe me what is this message would like to mean? Thx!

29 Aug 2011, 9:07 AM
The error quoted in the subject appeared when I was using IIS as the web server (WindowsXP). Now I moved to Tomcat, and I got a win32 exception. (Tried with both version 5.5 and 7)

26 Sep 2011, 1:07 PM
This is a top Google result so I wanted to add another detail for anyone else confused out there. I too got the "null is not a constructor" error when using the from-the-guide command, even though I am not using a dynamic language. The command is shown below:

sencha create jsb -a index.html -p app.jsb3

To remedy, I did what the OP did (sort of) and used the actual URL, however, including "index.html" (as shown in the Getting Started guide) produces a new error:

sencha create jsb -a http://localhost/application_manager/index.html -p app.jsb3

[ERROR] Ext is not defined, please verify that the library is loaded properly on the application's page
undefined:0 ReferenceError: Can't find variable: Ext

To get a complete working build, I excluded the index.html from the URL and this correctly created the .jsb3, which could then be built. The final command, then, was:

sencha create jsb -a http://localhost/account_manager/ -p app.jsb3

Maybe I made a mistake somewhere being it was my first time using Ext JS, but I'm pretty sure I simply followed the guide. Hope this can help somebody else that was confused like I was.