PDA

View Full Version : Sass/Compass config issues



markpoko
19 Jul 2011, 10:25 AM
Hey All,
I am developing an application, and would like to create a uniform custom theme for it. The general consensus has been to install and use Sass/Compass, so I set about and read up upon both and installed both.

I was able to install them(on OSX) with relatively no issues. I can compile the .scss files with no errors(just a few warnings about deprecated functions), however when I go to load the page all of the functionality from Sencha is not loaded. I tried multiple different things, than I figured if I can try compiling the main .scss file provided from the Sencha API. I @import the framework, and I @include everything, however the .css file is missing a large chunk of code(I diffed the provided file and the one i generated).

I believe my issue lies within the single @import in the .scss file. From my understanding, you are to point to the "../default/all" css file from the sencha API. The setup of my directory is like this:

/Directory/To/MAMP/htdocs/SenchaAPI
/Directory/To/MAMP/htdocs/ProjectFolder
/Directory/To/MAMP/htdocs/ProjectFolder/Resources
/Directory/To/MAMP/htdocs/ProjectFolder/Resources/SCSS
/Directory/To/MAMP/htdocs/ProjectFolder/Resources/CSS

In my application.scss file(in projectfolder/resources/scss) I have the line
"@import '../../../SenchaAPIFolder/resources/themes/stylesheets/default/all';

I have followed the directions of the sencha blog here:

http://www.sencha.com/blog/an-introduction-to-theming-sencha-touch

and some great insight from this user here:

http://www.sencha.com/forum/showthread.php?127607-Mastering-the-Compass-SASS-Setup-with-Sencha-Touch

Any help or insight onto how exactly the config/@import should be phrased would be greatly appreciated.

Mark Poko

markpoko
19 Jul 2011, 3:56 PM
I believe I fixed my issue!

I got frustrated, and decided to just try from scratch on a home computer. Like "magic" it worked (almost!) right out of the box. The only changes that were necessary were the @import statement in the .scss file.

I believe the main issue may have been with me messing around with many config.rb files, so I will just do a clean swipe of my api and see if thats the issue. The other issue may be related to the version I was using(1.0.1a), as it seemed many people had issues with using sass.

If anyone has any further insight, or is working on a tutorial on installing/configuring Sass-Compass correctly, let me know.