PDA

View Full Version : [CLOSED] Extjs 4.0.5 throws error with Ext JS 3 Compatibility Layer



frankiew
3 Aug 2011, 7:18 AM
When i change from extjs 4.02 to 4.05, it shoulds an error in ext3-compat.js, operation is undefined
[Break On This Error] if (this.sortParam && ...s && operation.sorters.length > 0). that's because getParams methods in Ext.data.ServerProxy is expecting (operation) while in 4.02 and Compatibility layer is expecting (params, operation).

Christiand
3 Aug 2011, 12:51 PM
having same error here.

brian.moeskau
3 Aug 2011, 2:39 PM
It will be fixed in the next revision of the compat layer. You can just edit the file and remove the first arg.

malstroem
27 Sep 2011, 4:47 AM
@Brian: any schedule for an updated CompatLayer?
I am using Ext 4.0.6 and have the same problem...

brian.moeskau
29 Nov 2011, 7:08 PM
Just realized that I never replied to this. The compat layer was updated on Oct 10 on the download page (http://www.sencha.com/products/extjs/download/), so hopefully this issue is now resolved.