PDA

View Full Version : LiveGrid and Ext 3.4.0



brookd
21 Sep 2011, 3:58 PM
Is LiveGrid Dead?

I can't get it to work with 3.4.0, specifically the selection model doesn't work. Everything looks out of date with livegrid on its Wiki site.

I thought it was such a popular component, and I don't think its dead cause mindPatterns (thourston) said he would eventually add support for Ext 4.0, but does anyone have the selectionModel working for 3.4.0?

Can some one help me (I'll even pay for the help), get it working on 3.4.0? My problem is there are no selections, single or other. I can't get a row to select or any row selection events to fire. I saw a hack in the forums, but I really want to use the cross data-set selection functionality that is built in rather than just a hack. Anyone?

daddie888
22 Sep 2011, 12:22 AM
Hi, i use livegrid in Ext 3.3.1 but had to modify it to make it compatible with that version an to let it work together with other add-ons. No need for it in ExtJs4 since it supports this functionallity nativly.
Is this a upgrade of an existing project ? From what version ?
If it is a new project i advise using version 4.
Grtz

brookd
23 Sep 2011, 5:42 AM
Moving to 4.0, would cost me 10,000+ in development costs, if not twice that much. Its not a viable option yet because I am still trying to push something out the door. Too many breaking changes and code rewrites in 4.0 for me just now. I plan to upgrade at some point...

But where is mindPatterns? Does anyone have the row selection model working with liveGrid and 3.4.0?