PDA

View Full Version : works great in chrome but not in explorer or firefox



johnleigh
4 Oct 2011, 8:55 AM
hi guys,
first time trying this out and a simple logo and text animation plus video looks good in chrome, but viewing in firefox and explorer the logo and the text default to x=0 and y=0 and is unusable. video dsnt work in explorer of course and realise that in browsers that dont support the css3 animation features browser will ignore positioning - what is your advice on ensuring that in those browsers the layout is actually decent/useable?

best regards
john in london

arnebech
4 Oct 2011, 9:22 PM
hi john,

We have a story in our backlog to address a basic static fallback for unsupported browsers, but we haven't gotten there yet. In your case you could perhaps use modernizer or an equivalent library to detect css3 transform/animation support and substitute in a replacement in unsupported browsers.

We are working on adding support for firefox.

zeeuge
6 Jan 2012, 11:24 AM
when are you making it for the firefox? last time i checked firefox is quite popular.. i can't deploy your product unless it's cross-platform, am I the only one in this?

arnebech
6 Jan 2012, 11:55 AM
Sorry, I can't discuss specific dates. But we are definitely working on this.

CaliLuke
12 Jan 2012, 12:05 PM
when are you making it for the firefox? last time i checked firefox is quite popular.. i can't deploy your product unless it's cross-platform, am I the only one in this?

Animator is mostly targeted for mobile animations, so supporting Firefox is a lesser priority. Said so, experimental support for Firefox animations is now available in the lastest update, test drive it and tell us what you think.

http://www.sencha.com/blog/sencha-animator-1-1-now-available/

Thanks!