PDA

View Full Version : Deployment of an extJS web application



Thomas Sauder
5 Oct 2011, 12:35 AM
Hi all,

i am using ExtJS Designer 1.2 and ExtJS 4.0.2a for development.
To start my app I use this code:


<!DOCTYPE html>


<!-- Auto Generated with Ext Designer -->
<!-- Modifications to this file will be overwritten. -->
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>testInfo.xds</title>
<link rel="stylesheet" type="text/css" href="http://extjs.cachefly.net/ext-4.0.2a/resources/css/ext-all.css"/>
<script type="text/javascript" src="http://extjs.cachefly.net/ext-4.0.2a/ext-all-debug.js"></script>
<script type="text/javascript" src="app/view/ui/DriveOnWebInfo.js"></script>
<script type="text/javascript" src="app/view/DriveOnWebInfo.js"></script>
<script type="text/javascript" src="designer.js"></script>
</head>
<body></body>
</html>


It looks great in all browsers.
But when I copy the ext files to local file system and change my above code to


<!DOCTYPE html>


<!-- Auto Generated with Ext Designer -->
<!-- Modifications to this file will be overwritten. -->
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>testInfo.xds</title>
<link rel="stylesheet" type="text/css" href="ext-all.css"/>
<script type="text/javascript" src="ext-all-debug.js"></script>
<script type="text/javascript" src="app/view/ui/DriveOnWebInfo.js"></script>
<script type="text/javascript" src="app/view/DriveOnWebInfo.js"></script>
<script type="text/javascript" src="designer.js"></script>
</head>
<body></body>
</html>


all looks stille fine in Firefox and Chrome but not in Internet Explorer. For example the buttons became white.
Screenshot first code IE9 (OK):
28523

Screenshot second code IE9 (white buttons)
28524

Does anybody has an idea why IE9 behaves different?
With kind regards
Thomas