View Full Version : tabPanel.activate vs tabPanel.activateTab

4 Jan 2007, 5:54 AM
Last night while i was working with a tab panel i noticed something in that of all the properties activate was the only one that didn't have `Tab` on the end of it.

I am wondering why this is like this, to me it would make sense to have it be activateTab as that way it follows the rest of the properties that deal with tabs (ex: disableTab, enableTab, hideTab, showTab).

Just an idea.


9 Sep 2007, 7:33 PM
I think it's because activate is an event that can be handled. hide/show/enable/disable are methods of the Tab. Maybe it's just a convention for separating events from methods that alter the state of the object in question?

10 Sep 2007, 11:21 AM
This has been resolved for a while now... i think that was back in ext .4

but thanks for the reply.