View Full Version : JSDuck missing ext/default/all

14 Oct 2011, 11:53 AM
I'm trying to build a custom jsduck gem to support translated documentation, but the first step is to get JSDuck building/working from source. I keep running into this error:

error template/resources/sass/docs-ext.scss (Line 16: File to import not found or unreadable: ext4/default/all.
Load paths:

I was able to find mention of this in the FAQ which suggested that the config.rb file needs to have the correct path to Extjs. I currently have ext-4.0.2a symlinked into ../template/extjs (per the instructions). I've tried using both the default (../../extjs) and an absolute path (/Users/bdurette/Tools/extjs-4.0.2a) for $ext_path but neither seem to work.

Some differences that I know of (but don't think are causing the problem (but I could be wrong)):

1. Using Ruby 1.9.2. I did have to make one change to the Rakefile to make this work, so I'm guessing Sencha is not using 1.9.2.
2. Using 4.0.2a, not 4.0.6.

Any pointers on how to get this working would be greatly appreciated.


17 Oct 2011, 7:51 AM
I've managed to make some progress on this, so I'll reply for posterity. I've managed to get past this by:

1. Checking out the 3.0.pre2 tag (was using HEAD).
2. Downgrading to Ruby 1.8.7 (from 1.9.2).
3. Downgrading SASS to 3.1.1 (from 3.1.10).

Doing these things gets me beyond the ext/default/all problem but leads me to another issue, which will be the topic of another thread.

18 Oct 2011, 7:54 PM
thank the many, this is my problem, now I have solved it:))