PDA

View Full Version : Row editing and checkbox selector is not compatible in 4.0.7



ahmettaha
21 Oct 2011, 12:05 PM
Hello,

I would like to know if anyone else has experienced this issue.

I have a grid that has row editing and checkbox selection model. It was working perfect in 4.0.2a. However , today when I upgraded to 4.0.7, the row editor started acting weird. I didnt display the checkbox that I had at the beginning of each row. Moreover, the row editor input boxes were misaligned. Moreover, the row editor input indexes were not maching with the column that I was double clicking to start the editing mode.

with many hours of debugging, I have found a hack to fix this problem temporarily.

you must comment out the line below in Ext.grid.RowEditor


onFieldRemove: function(map, fieldId, column) {
var me = this,
field = column.getEditor(),
fieldEl = field.el;
// me.remove(field, false);
if (fieldEl) {
fieldEl.remove();
}
},


I dont know why it works, but it just works.

ahmettaha
23 Oct 2011, 2:52 PM
bump