View Full Version : [CLOSED] Some config fields not retaining changes

13 Nov 2011, 10:28 AM
I am working my way through the Expense Report tutorial and I am having troubles adding some configuration changes. When I try adding an array to the 'options' config and then click 'Enter' I get a new line rather than saving the info. I also tried moving to a different config parameter but find that the 'options' field then becomes empty. This also occurs with the 'style' config option. Am I missing something or is this a bug?



21 Nov 2011, 1:30 PM
After you are done entering data, try clicking on another field or use tab. Agree the usability of this editor could be improved.

21 Nov 2011, 2:22 PM
I have tried both those things and it is still not saving the value. My specific problem is with a Select Field on a form. The Ext.field.Select 'options' configuration does not allow you to place text e.g.. [{text:"Uncategorized",value:null},{text:"Lodging",value:"lodging"},{text:"Transportation",value:"transportation"},{text:"Food/

and then save it.

1 Dec 2011, 4:27 PM
anoble -

I just tested this with the above set of options as you pasted and it worked fine.

The only thing that I needed to adjust was the carriage return in between "Food/" and "Drink". This makes what you pasted an invalid object literal.