PDA

View Full Version : [2.0b1] charset on Ext.form



wilfuler
19 Oct 2007, 1:45 AM
First of all, I really appreciate for your jobs on this magic project.
Thank all of you!

I come from China, so I changed (examples/form/dynamic.html)


<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

into


<meta http-equiv="Content-Type" content="text/html; charset=GB2312">


However, it occures unexpected changes, please look at the attached pictures, "The bottom line is lost."

It's all right in Firefox 2.0.0.8, but not IE 6.0.2900.2180.xpsp_sp2_gdr.070227-2254.

Please check it.
Thanks.

wilfuler
21 Oct 2007, 4:48 PM
Sorry, I have put this thread in "Ext Community Forums (1.x)", thank the one who moved it here. I won't do like that anymore.
BTW, hoping someone can give me a hand. Thanks.

fangzhouxing
21 Oct 2007, 6:18 PM
You must patch css yourself like this:



.ext-ie .x-form-text {
margin-top:1px;
} /* the textField missing bottom line */

wilfuler
21 Oct 2007, 10:17 PM
It still doesn't work, until I change "margin-top" into "2px".

However, another problem came out:
1) If you set labelAlign: 'left', your input text will below the label about 2px, so it looks a bit strange. (see 1.jpg)
2) In another page, I set labelAlign: 'top', then the combox's arrow looks 2px higher than the textfield.(see 2.jpg)
When I can change "margin-top" into "-2px", the combox's top line seems lost.(see 3.jpg)

Well, thank you all the same!

BTW, I used Ext.form.FieldSet, but I don't wanna set its title, so it remains a little blank area, how can I get rid of it?(see 1.jpg top-left)

wilfuler
23 Oct 2007, 4:47 PM
Could you give me some suggestion?

fangzhouxing
23 Oct 2007, 5:13 PM
1) If you set labelAlign: 'left', your input text will below the label about 2px, so it looks a bit strange. (see 1.jpg)
2) In another page, I set labelAlign: 'top', then the combox's arrow looks 2px higher than the textfield.(see 2.jpg)
When I can change "margin-top" into "-2px", the combox's top line seems lost.(see 3.jpg)

hi,wilfule,I have these same problems, and not found any solutions.

wilfuler
23 Oct 2007, 9:35 PM
Thank you for giving your attention.