View Full Version : Build Successful But App Not Running

7 Dec 2011, 10:46 AM
I built my app by following the getting started guide. When I run the app I get
"NetworkError: 404 Not Found - http://localhost/j/WOM/view/WOM/view/statusList.js?_dc=1323282504422". Why is this going on. My application name is WOM. But the generated path is not correct. I do have a view directory, I followed the MVC structure, but my app is not structured the way the path is generated. My path to the target js is app/view/statusList.js. That's all. Where did all the other path-ing come from? I'm I doing something wrong. I have attached the jsb file, but nothing seems wrong in there to me.

9 Dec 2011, 9:20 AM
This is most likely caused by not using requires/uses properties throughout your application files properly.

9 Dec 2011, 3:18 PM
I have tried to supply Ext.require() for all classes that depend on another class. I also went back and read the application doc and added all views, controlers and models. Even though the app doc says you can supply stores config, the builder will blow up. So I left the stores config out. But now, when I run with the build output, I only see the title of my index.html. I don't get any warning or errors. One thing I did find is if you use autoCreateViewport (http://docs.sencha.com/ext-js/4-0/#%21/api/Ext.app.Application-cfg-autoCreateViewport):true config option of Application class, the builder will hang during create jsb. I've ran out of things I can think of to try. Can I post my app to get some help or can you suggest some more things to try? We would really like to run from the project build. Thanks.