PDA

View Full Version : How to even started with Sencha IO>???????



Di Peng
15 Dec 2011, 10:17 AM
Hi,
I have downloaded the Sencha.IO SDK. I included sencha-io-debug.js in my index.html like following:

<body>
<script src="lib/touch/sencha-touch-debug.js" type="text/javascript" charset="utf-8"></script>
<script src="sencha-io.js" type="text/javascript" charset="utf-8"></script>


<div id="sencha-app">
<script type="text/javascript" src="app.js"></script>
</div>
</body>

And I get this error:

1 (http://pd.local:8881/testio/sencha-io.js)Uncaught TypeError: Cannot read property 'Batch' of undefined

Apparently the error comes from the very first line: Ext.data.Batch.override({.....

Anyway. I also cannot seem to get Ext.io to work.

Any suggestion on how to get started will be greatly appreciated. My company needs to check out Sencha IO's messaging service.

If it is not ready yet. I also hope to know. So I don't have to poke around the code anymore

Di

mitchellsimoens
15 Dec 2011, 10:22 AM
You are using ST1 correct? Also, have you checked out the API doc for Sencha.io? When you login, there is a link in the right column

Di Peng
15 Dec 2011, 10:27 AM
No I am using ST2 PR1 for this.
Should I be using ST2 PR2?

And I did check out the API. but it does not help me get rid off the error on the first line of code. Help needed.
Thanks
Di

mitchellsimoens
15 Dec 2011, 10:30 AM
I don't believe the Sencha.IO stuff is working in ST2 yet. ST2's API isn't frozen so some things are being held off because we are still in the PR stages.

Di Peng
15 Dec 2011, 10:32 AM
I see. Thanks a lot. I ll using ST1 to play with IO then :)

Di Peng
15 Dec 2011, 11:48 AM
Hi Mitchell,
Thank you so much for your patience and quick response.
I tried IO with ST1. But got this error: TypeError: Cannot read property 'WebStorage' of undefined

What is confusing to me is that sencha-io.js is using ST2 syntax such as:
Ext.define('Ext.io', {.....

I still have no luck to get it started.
I cannot even get hold of Ext.io. I tried Ext.io => undefined
Basically it should not work because in ST1, Ext.define => undefined

merrells
19 Dec 2011, 1:15 PM
Hello,

The Sencha.io SDK only works with ST2 PR2. If you are still having problems then email me at merrells @ sencha.com and I'll help you get past this versions issue.

John

merrells
8 May 2012, 7:10 PM
We recently shipped an update to SIO that works with ST2. You can download it here:

http://download.sencha.io

John

Di Peng
10 May 2012, 6:39 PM
Awesome! will check it out immediately