PDA

View Full Version : Grid with grouped header - browser hangs



loxodon
17 Dec 2011, 7:31 AM
Hello,
I have a grid with 20 columns which uses a store with data from php backend. Everything is fine when i display it with all separate columns. But when i group several columns into grouped headers (lets say 12 separate columns and 4 double-column groups), the browser waits few seconds and then hangs. Tried in firefox 8 and opera 11 and it happens everytime. Is there something i could use to fix it?
Here is some code from Ext Designer with this grid:

Ext.applyIf(me, {
viewConfig: {

},
columns: [
{
xtype: 'gridcolumn',
dataIndex: 'data1',
text: 'DATA1'
},
{
xtype: 'gridcolumn',
dataIndex: 'data2',
text: 'DATA2'
},
{
xtype: 'gridcolumn',
dataIndex: 'data3',
text: 'DATA3'
},
{
xtype: 'gridcolumn',
dataIndex: 'data4',
text: 'DATA4'
},
{
xtype: 'gridcolumn',
text: 'GROUP1',
columns: [
{
xtype: 'gridcolumn',
dataIndex: 'data5',
text: '%'
},
{
xtype: 'gridcolumn',
dataIndex: 'data6',
text: 'VAL'
}
]
},
{
xtype: 'gridcolumn',
dataIndex: 'data7',
text: 'DATA7'
},
{
xtype: 'gridcolumn',
dataIndex: 'data8',
text: 'DATA8'
},
{
xtype: 'gridcolumn',
dataIndex: 'data9',
text: 'DATA9'
},
{
xtype: 'gridcolumn',
text: 'GROUP2',
columns: [
{
xtype: 'gridcolumn',
dataIndex: 'data10',
text: '%'
},
{
xtype: 'gridcolumn',
dataIndex: 'data11',
text: 'VAL'
}
]
},
{
xtype: 'gridcolumn',
dataIndex: 'data12',
text: 'data12'
},
{
xtype: 'gridcolumn',
dataIndex: 'data13',
text: 'DATA13'
},
{
xtype: 'gridcolumn',
dataIndex: 'data14',
text: 'DATA14'
},
{
xtype: 'gridcolumn',
text: 'GROUP3',
columns: [
{
xtype: 'gridcolumn',
dataIndex: 'data15',
text: '%'
},
{
xtype: 'gridcolumn',
dataIndex: 'data16',
text: 'VAL'
}
]
},
{
xtype: 'gridcolumn',
text: 'GROUP4',
columns: [
{
xtype: 'gridcolumn',
dataIndex: 'data17',
text: '%'
},
{
xtype: 'gridcolumn',
dataIndex: 'data18',
text: 'VAL'
}
]
},
{
xtype: 'gridcolumn',
dataIndex: 'data19',
text: 'DATA19'
},
{
xtype: 'gridcolumn',
dataIndex: 'data20',
text: 'DATA20'
}
],

mitchellsimoens
17 Dec 2011, 7:48 AM
Can I get a sample response so I can try against 4.0.7 and 4.1.0 beta 1?