View Full Version : Images not showing in Animator

17 Dec 2011, 10:03 AM
I just downloaded Sencha Animator to evaluate, and no matter what I try, when I place an image on the canvas and set the source image path, it doesn't show the image, just a question mark icon. I've searched the forums and it seems that others had this issue in the past and it may have been resolved. However it's not working for me. Is this still a bug, or am I doing something wrong? I've been following the directions for adding a new image found in the Guided Tour (http://www.sencha.com/learn/animator-guided-tour/)

I'm running Animator on Windows 7.


19 Dec 2011, 8:29 AM
Sorry you're having issues with Animator.

Does the sample image show up when you use the image tool in the toolbar to the left and place it on the screen?

Also, after your project is saved, have you tried dragging an image into animator from the filesystem?

19 Dec 2011, 9:53 AM
When I use the image tool to place an image on the screen, it does show the sample image (icon of mountains with sun). I tried dragging an image from the filesystem to the canvas, and it has the same result as adding an image using the image tool- shows sample image icon and path in properties panel reads "example://images/shape.png"

However I think I found a work-around.

Let's say I have an image I want to use in this path: c:\some_project\some_images\myImage.jpg
If I add a new image using the image tool, then click the button in the image's properties panel to browse to the image source and select it, the resulting path in the properties panel reads "asset://myImage.jpg", which doesn't work.

If I manually enter the full path "c:\some_project\some_images\myImage.jpg" in the properties panel it will work. Although I've found that this only seems to work with paths beginning with a drive letter and not network paths like "\\network_computer_name\shared_drive\some_project\some_images\myImage.jpg". Fortunately than't not an issue since I can map a network drive to a drive letter.

19 Dec 2011, 11:42 AM
It seems that using full paths in the image properties (as mentioned in my previous post) won't work for the exported html file. I've moved all my images to the assets folder that is created when you save a project. I can import them from there and they'll show up in Animator and also be correct in the exported html file.

19 Dec 2011, 2:27 PM
Glad you found a workaround.

Sounds like maybe the issue is related to network drives? Have you tried importing an image from your local hard drive?

22 Dec 2011, 6:15 AM
Yes, the issue is identical if the image is imported from a local drive. It seems like a possible bug since the path that gets automatically put in the properties panel is not the path of the selected image. The path would only be correct if Animator copied the file from it's original location into the assets folder for the project, which doesn't happen. I'm not sure what the correct behavior of Animator is supposed to be.

22 Dec 2011, 7:56 AM
Normal Animator behavior is to copy any image into the asset folder, but it sounds like that doesn't happen for some reason on your computer. When you export a project with images, does that work?

8 Jan 2012, 7:21 AM
I have found that for some reason in Animator images are not showing if the file anim file il saved on a share like \\somewhere\someshare\myanim.anim

A workaround for that is to mount the share in a letter and not accessing it directly.

I dont know if this could be considered a bug, but when working on a large intranet could be useful to access the share by name without associanting with a letter.

For all the rest sencha animator il just great! :)

9 Jan 2012, 9:05 AM
Yeah, that sounds like a bug. Thanks for pointing that out. I'll add it to our backlog.