PDA

View Full Version : [2.0b1][CLOSED] Desktop Demo on Firefox 2.0.0.8:illegal string was specified" code:12



erchan_2000
28 Oct 2007, 10:27 AM
Please refer to
http://extjs.com/forum/showthread.php?t=9340&highlight=renderElements+illega
for problem found in Ext 1.1

Looks like the problem (probably not the same) is happening in Ext2.0 Beta1

I ran the Desktop demo with Firefox 2.0.0.8 and the Accordion Window does not render the TreePanel with the treenodes filled in.

I'm getting the exact same error as mentioned (invalid string error, code 12).

I also noticed when I'm running Safari 3 beta on MAC/XP, and the desktop taskbar doesn't render as well. Everything seems to work on IE7 though.

I was wondering if I'm missing something on the browser side. Is there like a switch I need to enable/disable?

It's hard to debug my work using IE browser. Firebug really helps in debugging my JScripts.

thanks!

jsakalos
28 Oct 2007, 2:21 PM
Sorry, I haven't been able to reproduce it neither in FF-2.0.0.8@Linux nor FF-2.0.0.8@WinXP using http://extjs.com/deploy/dev/examples/desktop/desktop.html.

Any special procedure?

erchan_2000
28 Oct 2007, 8:25 PM
Interesting ...

Could you provide the source code for the Desktop demo you used?

I'm currently using the source code from ext2.0 beta1, which may be outdated compared to your latest demo code?

I'm also running JBoss 4.2.1, so maybe that could be a problem?

Thanks!

jsakalos
29 Oct 2007, 1:41 PM
I've used link in the previous post to test - on-line example.

erchan_2000
30 Oct 2007, 8:41 AM
Thanks for the info.

I believe the on-line example contains bugfixes not found in Ext-2.0Beta1. The desktop example was not functional until I changed the file "desktop.js" to "Desktop.js". The bugfix was reported a while ago, so the online example probably has some fixes (in ext-all.js or in demo code) which aren't in the Beta1 code.

Any chance you could do a "diff" or provide the complete source code of the Desktop demo for me to try out?

Thanks!

jsakalos
30 Oct 2007, 9:06 AM
There are fixes in svn, of course. The Ext 2.0 final will be out soon, hopefully you can wait until then...;)

erchan_2000
30 Oct 2007, 11:33 AM
Sure thing ... I wasn't awared that the on-line demo is the latest from SVN.
My initial impression was it is from the same codebase as Beta1. I guess I'm wrong.

Will try out the GA codebase when it comes out and see if the problem persist.

Thanks!

mystix
30 Oct 2007, 8:13 PM
Sure thing ... I wasn't awared that the on-line demo is the latest from SVN.
My initial impression was it is from the same codebase as Beta1. I guess I'm wrong.

Will try out the GA codebase when it comes out and see if the problem persist.

Thanks!

just to clarify, the online samples are still on Ext 2.0 beta1a, the same version as the one in the official download available here (http://extjs.com/download). it's definitely not the SVN version. HTH.

p.s. i've marked this thread title [CLOSED]. feel free to [REOPEN] this again once the next official download becomes available and the bug still exists then. thanks.