PDA

View Full Version : Help Me Change Theme?



RandomAbstract
28 Dec 2011, 10:53 AM
I am not able to figure out how to select the Gray theme in 3.x. First, is it available. Second, any help? Thanks.

Colin Alworth
31 Dec 2011, 11:06 AM
The Gray theme is not available as of Beta 1. When it is available, it can be selected by adding the theme's module to your own module file. That line will look something like


<inherits name="com.sencha.gxt.theme.gray.Gray" />

To see how themes are defined in GXT 3, take a look at the Blue.gwt.xml file in the com.sencha.gxt.theme.blue package - it is extending the com.sencha.gxt.theme.base.Base module, and adding colors and images - gray and other colors will be implemented in the same way. Other themes that require completely different DOM structure can be implemented by just building new appearances, and rebinding them (as seen in Blue.gwt.xml and Base.gwt.xml).

Ltty
30 Mar 2012, 2:08 AM
Is the theme available in beta 4? Because I'm inheriting from the theme but basically still get the blue one.

icfantv
30 Mar 2012, 1:59 PM
It is still not available. Even in the lastest RC release from a few days back. Given the number of bugs and issues they've been fixing between beta releases (from the release notes), this probably has not been high on their priority list.

However, I would imagine it will make the official release.

paucarre
1 May 2012, 11:35 PM
Hello,
I am trying to change the blue theme for the gray one. I am using the GXT 3.0.0 release and I add this line to the .gwt.xml file: <inherits name="com.sencha.gxt.theme.gray.Gray" />

But the application still uses the Blue theme and I dont know why.

Colin Alworth
2 May 2012, 5:42 AM
As we mentioned in the blog post at http://www.sencha.com/blog/announcing-sencha-gxt-3-0/, the gray theme will be available in the next release. We decided to go to 3.0.0 without this to put finalized code in developer's hands as soon as possible with enough of a guide to show how to build a new appearance like gray.

vkeswani
20 Feb 2013, 11:44 AM
I have upgraded to 3.0.4 and it still doesn't work. Is this theme available for use?

tbenbrahim
11 Apr 2013, 7:36 PM
it works in 3.0.1