View Full Version : Ext.Loader is not enabled

2 Jan 2012, 7:16 AM
Hi all,

I have my user interface built on 4.0.2a. Now I am trying to use 4.1 beta but I get the following error in Firebug:

Ext.Loader is not enabled, so dependencies cannot be resolved dynamically.

Even though I have the following lines in my code:

Ext.Loader.setConfig({enabled: true});
Ext.Loader.setPath('Ext.ux', '__SENCHA_SYSTEM_URL__/extjs/examples/ux/');

Does anyone know the solution to this problem or has also encountered it?


2 Jan 2012, 7:24 AM
This is how I do it (and it works).

enabled: true,
// Don't set to true, it's easier to use the debugger option to disable caching
disableCaching: false,
paths: {
'wag.floorplan': contextRoot + '/wag/floorplan/js'

2 Jan 2012, 11:48 PM
Thanks for your suggestions LesJ but it didn't work for me :(

I set disableCaching to false and also set the paths config instead of using setPath method but no affect...


3 Jan 2012, 11:04 AM
Which js file are you using?

Where are you putting those lines to enable the loader?

It might help if you post the top of your HTML file so we can see how you're including things.

3 Jan 2012, 11:54 PM
Thanks for your response. I am using ext-all-debug.js from 4.1.0 beta. Here is my HTML file:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

<link rel="stylesheet" type="text/css" href="./Sencha/extjs/resources/css/ext-all.css" />
<link rel="stylesheet" type="text/css" href="./Sencha/extjs/examples/shared/example.css" />
<link rel="stylesheet" type="text/css" href="./Sencha/extensible/resources/css/extensible-all.css" /> <link rel="stylesheet" type="text/css" href="./Sencha/extensible/examples/examples.css" />
<link rel="stylesheet" type="text/css" href="mycss.css" />

<script type="text/javascript" src="./Sencha/extjs/ext-all-debug.js" ></script>
<script type="text/javascript" src="./Sencha/extensible/extensible-all-debug.js" ></script>
<script type="text/javascript" src="./Sencha/extensible/Extensible.js" ></script>
<script type="text/javascript">Ext.Loader.setConfig({enabled: true, disableCaching: false, paths: { 'Extensible': './Sencha/extensible/src', 'Extensible.example': './Sencha/extensible/examples/' }});</script>
<script type="text/javascript" src="myJS1.js" ></script>
<script type="text/javascript" src="myJS2.js" ></script>
<script type="text/javascript" src="myJS3.js" ></script>
<script type="text/javascript" src="myJS4.js" ></script>
<body> </body>

The loader config is in myJS1.js on the top before the on_ready function. I also tried it inside the on_ready function but it didnt make a difference. The same HTML and JSs worked perfectly with Ext JS 4.0.2. Could it be because of the Extensible library somehow? because of setting the load config for it first in the HTML file?


4 Jan 2012, 12:19 AM
It looks to me like you're configuring the loader too late. Try putting it immediately after you include ext-all-debug.js.

4 Jan 2012, 12:48 AM
yes that worked! Thanks! now the error is gone but still my application doesn't work. Instead of a whole page loaded, I just see a small rectangle on the top left corner of the screen... Anyway, I think I will stick for 4.0.2 for now and migrate to 4.1.0 when its working properly. I have read many users quote that their application didn't work at all with 4.1.0.


4 Jan 2012, 12:53 AM
Indeed, 4.1.0-beta-1 is just a beta, it'd be brave or foolish to try to use it in a production environment.

If you're still on 4.0.2 it might be worth upgrading to 4.0.7. It'll be a smaller jump than 4.1.0 and you'll get a lot of bug fixes and performance improvements. 4.0.7 is a lot more stable than 4.0.2.

4 Jan 2012, 1:04 AM
Yes. I did notice some bugs in 4.0.2 which have been fixed in 4.0.7 but my application is nearly complete now and I dont want to change things at the moment. I tried with 4.0.7 once but the layouts of windows etc. were not the same as with 4.0.2 and there were problems with comboboxes. But eventually, I will move to 4.0.7. It seems that with every change in the ExtJS version, the user will have to make changes in his/her own code to make it work...

Thanks for your suggestions.