PDA

View Full Version : Menubar icons not showing



captainm1uk
8 Nov 2007, 7:17 AM
I have implemented the menu bar on a form and when I op0en up the form in a new page it works fine. But strange things happen when I open it up in read mode or edit mode in a layout.

Image 1 and 2 are how they look in a new window

Image 3 and 4 are when they are opened up in a center layout in read or edit mode

Can anyone explain ?

galdaka
8 Nov 2007, 9:41 AM
Review your relative / absolute paths.

captainm1uk
8 Nov 2007, 11:57 AM
Thanks - but what about the gap at the top ?

bhaidaya
9 Nov 2007, 8:09 AM
are the actions manually coded? or are they built from the ext.nd DXL agent?

Do your actions have hide formulas?

Verify that your layout doesn't have hide formulas based on edit/read mode that would break the html structure.

Does it bomb in ie?

The images breaking suggests exactly what galdaka wrote. but the space makes me think you got some weird hide formula issue messing with your html structure.

captainm1uk
9 Nov 2007, 8:26 AM
The action bar is not built using extnd but using the menu bar widget - so in edit mode in a full page it displays fine - if it is in edit mode on the center frame then you get the gap at the top

Yes it could be a hide formula - will check it in ff to see

jratcliff
9 Nov 2007, 9:23 AM
If you are saying it works for a "new" document then the typical domino url is like so:

http://server/db/form?OpenForm

But the url for a document that already exists (whether you are opening it in read or edit mode) is like so:

http://server/db/view/unid?OpenDocument (or ?EditDocument). Note that "view" doesn't even have to be a real view in the db and you'll see many developers use "0".

In any case, "view" introduces an extra level to the path so if you have set Ext.BLANK_IMAGE_URL to be a relative path that doesn't automatically compute to including the view when viewing/editing existing documents then that could be your problem.

captainm1uk
12 Nov 2007, 8:34 AM
Hi

The path of the blank image is Ext.BLANK_IMAGE_URL = '/" + x +"/ext/resources/images/default/s.gif';

This is in the Head section and "x" refers to @webdbname so not too sure what you mean

Thanks