PDA

View Full Version : Problem with updatemgr



j555
21 Jan 2007, 6:56 PM
I have a script that uses updatemgr and everything works great. However when I try to implement YAHOO.ext.UpdateManager.defaults.loadScripts = true; it breaks IE.

My problem is everything works fine in firefox but IE throws a javascript error. I am using yui-ext 0.40. Has anyone seen this issue?

Thanks for the help.

j555
21 Jan 2007, 7:10 PM
The same thing happens when I run

Mgr.loadScripts = true;

instead of

YAHOO.ext.UpdateManager.defaults.loadScripts = true;

tryanDLS
21 Jan 2007, 7:11 PM
You'll have to provide more details. What/where is the error occurring? Does it occur with .33? Can you post a sample?

j555
21 Jan 2007, 7:43 PM
Following is the javascript portion of the code I am having problems with. I get the same error with .33 that I get with .40. Firefox works the way I expect it to. IE does not.

//index.php
function openPage(currentid){
var getPage = getEl('page');
var pageMgr = getPage.getUpdateManager();
pageMgr.loadScripts = true;
pageMgr.update('getpage.php', 'id='+currentid);
}




//getpage.php

<script language="JavaScript" type="text/javascript">
<!--
var Listener = function() {
currentKey = document.getElementById('textbox').value;
var getPage2 = getEl('inner2');
var mgr = getPage2.getUpdateManager();
mgr.update('page2.php', 'id=1');
};
YAHOO.util.Event.on('textbox', 'keyup', Listener);
//-->
</script>

<input type="text" name="textbox" id="textbox" size="15" />

j555
21 Jan 2007, 7:50 PM
Sorry, forgot to mention that the error is on the line:

pageMgr.loadScripts = true;

tryanDLS
21 Jan 2007, 8:03 PM
Take a look at this thread - I think your comment tags may be the problem
http://www.yui-ext.com/forum/viewtopic.php?t=1442&highlight=loadscripts+error

j555
21 Jan 2007, 8:13 PM
Thank you for the link, that was the problem. All is working great. THANKS...