PDA

View Full Version : X-UA-Compatible meta tag recommendation for Ext 4



DocAhrens
7 Feb 2012, 6:47 PM
What is Scencha's recommendation for supported use of the "X-UA-Compatible" meta tag?
On your site you have:

<meta http-equiv="X-UA-Compatible" content="chrome=1">
You have:

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=8" /><![endif]-->
You have:

<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=8" /><![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
and what about:

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

Your statement in numerous places throughout your forum, that you will not support compatibility mode, seems to indicate that we should not be using meta tags like:

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=8" /><![endif]-->
but rather, you will be supporting:

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
Or, did I completely misunderstand your statement of "Ext will NEVER support [compatibility mode]"? Bottom line, can you discuss it among yourselves, and tell us what meta tag version will be supported (a.k.a. which one should we be using for maximum compatibility with ExtJS 4.x) going forward?

heratech
2 May 2012, 6:52 AM
Hi,
I would also like to know about this.
Thanks