View Full Version : [DUP] TreeNode root/data property confusion

8 Feb 2012, 4:51 PM
Trying out the new Sencha Designer and using the TreeStore. I worked to use designer to make an example that looked like the sample code on:


Strangely enough, Sencha Designer looked like it was giving me an error -- something like "Please associate a model .... inline data ... " on the TreeStore.

My question is if I fill out the root property why should I have to setup the data property (as the example does not bother to set the data property)? They both kind of seem to be doing the same thing exception the data property seems to work on an array of objects and root expects a dictionary object. I got my example to work by setting the data property to the empty list and setting the root property to what is in the sample code on the url.

Is there a good reason to have a data property for the TreeStore?

8 Feb 2012, 5:11 PM
cscortes -

Thanks for the post. Could you please post a sample project that illustrates your problem?

After creating the project go to File -> Export/Archive Project and then post the .xda file here on the forums.

9 Feb 2012, 2:07 PM
Here is the sample file. I tried to upload as an xda file, but it didn't like it. So I zipped it and it worked: 31558. Note that I changed the data back to null so if you loaded it in the new sencha designer you can see the warning bubble. If you set the data property to [], it goes away.


9 Feb 2012, 2:32 PM
Thanks for the bug report.

The issue is that the TreeStore should not be showing that warning when data is unset.

9 Feb 2012, 7:04 PM
This will be fixed in the next build, after build 276.