View Full Version : [INFOREQ] TypeError: 'undefined' is not an object

11 Feb 2012, 3:14 AM

i have moved a project between PC and MAC a couple of times and now i get the error

TypeError: 'undefined' is not an object

frequently when I switch from one view to another in the component inspector and i need to restart the designer.

is there anything i can do to solve it?

11 Feb 2012, 8:27 AM
Hi, I have exactly the same problem, but using the Designer on a PC. It crushes all the time with the same error message, especially when switching between views, or adding some new components to views

13 Feb 2012, 5:15 AM
I have the same error without switching from PC to MAC. The error occours very often. Most of the times on the 3rd or 4th action. It doesn't event matter what kind of action it is. Sometimes the error occours when changing the current file, when adding a new element to the view or when adding a Controller Reference. In about 5 minutes I have to restart the designer ~9 times.

13 Feb 2012, 10:20 AM
All of these errors are very critical to us (and you)! Could you please give us the steps to reproduce the errors so that we can fix them?

13 Feb 2012, 12:35 PM
the project attached to this thread has the "undefined" is not an object error


opening it I am still getting the error quietly often.

Same for the project attached to this thread...


So i believe is something not related to a specific project.

I am using a MAC with OSX Lion and a PC with Windows 7 and both of them give me the problem.

13 Feb 2012, 11:59 PM
When I create a new empty project everything works just fine. But when this project gets larger, it fails randomly on different actions. Therefore it's difficult to describe the steps to reproduce. Maybe it doesn't matter, but I am currently using the Designer in trial mode.
Windows 7 64-bit

14 Feb 2012, 3:41 PM

I get the same bug using the newest Ext Designer 2 Version on Linux 64 bit.

It appears on adding a Model to Models or a Controller to Controllers.

The other things just work fine.

15 Feb 2012, 2:31 PM
The error posted above is just a generic error. ANy time a crashing type error occurs this is what is displayed. That being said the above posts could consist of 4-5 different bugs. You are best off posting in your own thread exactly what triggered the error to occur and how you can reproduce it.

Note that in build 286 you are actually able to ignore/recover from bugs like this by clicking Ignore.

16 Feb 2012, 5:53 AM
Build 286 works much better.

28 Feb 2012, 2:36 PM
I'm now getting this error simply trying to start Sencha Designer 2.0.0 beta1. You double-click the program, nothing happens, wait a while, start another program it may/may not start, and sometimes need to click it a third time to get some sort of GUI to appear. No pattern as to which one will show the error but attached is a screen shot. I then close the duplicates and continue on my merry way using the program. I haven't had these "TypeError" messages whilst using the product, though.

28 Feb 2012, 2:39 PM
Marc what build version are you running? that was before we put in the ignore button. Can you upgrade?

28 Feb 2012, 7:20 PM
I'm using build 268. I may be fantasising here but I thought I read somewhere that the beta would keep itself up-to-date? In any case, I downloaded it from here (http://www.sencha.com/forum/showthread.php?152941-Sencha-Designer-2-Beta-Download-links) and the file size is exactly the same. I'll try uninstalling/reinstalling to be sure.

Update: the download is exactly the same; the build number of the latest download is build 268. It can't be a caching problem because I'm using a brand-new machine that is 2 days' old :-)

28 Feb 2012, 8:32 PM
Yes, if you have an internet connection it should auto-update to build 298.

Build 298 is not wrapped in the installer.

29 Feb 2012, 8:17 AM
Yeah auto-update needs a clear path to update servers. Firewall?

29 Feb 2012, 2:57 PM
Yeah auto-update needs a clear path to update servers. Firewall?

My employer has one almighty big firewall and proxy server that requires authentication. I did specify proxy server/username/password at the activation screen after install (which worked) but can't see whether this setting is still saved anywhere; I can't find a properties screen showing it, at least.

3 Mar 2012, 9:43 AM

I'm getting a typeerror on undefined on build 298 just opening up our project. I get the same thing again when I click "save".

"Ignore" does what it says on the tin.

Is there anythin I can do to help diagnose the issue we're encountering? (There's no js debugger/console available that I can spot yet).

I can send a copy of our project, but I'd prefer not to do so publicly.



5 Mar 2012, 5:47 AM
[FONT=Helvetica Neue]
Is there anythin I can do to help diagnose the issue we're encountering? (There's no js debugger/console available that I can spot yet).

I can send a copy of our project, but I'd prefer not to do so publicly.

Yes, please; let's figure out what it is.

Email it to designer.feedback at sencha.com and any more details that you wish to disclose in a non-public format.

9 Apr 2012, 2:29 PM
I had the bug too, i solved it by removing a "hasmanyassociation" entry in a file at metadata/model/*