View Full Version : Unable to load data using the supplied configuration.

25 Feb 2012, 9:09 AM
I encountered this error while doing the Designer 2 tutorial:

Unable to load data using the supplied configuration.
Open in Browser: data/cars.json

I can access the json file when I click the "data/cars.json" link in that message.

I'm using version 2.0.0 build 297. I tried this on 2 different boxes, one running Apache HTTP Server & the other IIS (both Windows XP).

I haven't seen this issue in the Designer 2 forums but I saw a nearly identical issue on the Ext Designer: Help & Discussion forum (http://www.sencha.com/forum/showthread.php?121378-Datastore-quot-Unable-to-load-data-using-the-supplied-configuration-quot) and I tried the following based on suggestions from that post but was unable to resolve the problem:

- Deleted the .localstorage file and then restarted Designer.
- Uninstalled Designer, deleted the entire "C:\Documents and Settings\[username]\Local Settings\Application Data\Sencha, Inc\Sencha Designer 2.0" directory and then reinstalled hoping to be able to change a proxy setting during the installation as indicated in the above post for the older version. There was no proxy setting that I could find either during the installation process or in any configuration dialog within the program itself.
- Changed the url prefix from http://localhost/carstore/ to the actual IP address.
- Tried various combinations of including/excluding leading/trailing slashes in the url prefix and the proxy url.

Any help is appreciated.


19 Jul 2012, 11:07 PM
I am having this exact same problem. I can't get any datastore to load in Sencha Architect, even though it works fine when I deploy the application.
The error message simply says "Unable to load data using the supplied configuration." and provides a link, when I click that link, I get to see the correct data.

I also tried deleting the local storage, that didn't help either.

Any help would be greatly appreciated.

19 Jul 2012, 11:20 PM
I figured it out, it was completely my own fault, as I had a case sensitivity issue with the root property of my Readers.
My apologies.