PDA

View Full Version : [FIXED] Disabling Radio not working



koenjan
28 Feb 2012, 6:59 AM
Hello,

(Using GXT3 beta3)
I'm trying to disable a com.sencha.gxt.widget.core.client.form.Radio:
In UiBinder, I tried readOnly="true" and enabled="false", but the radio is still editable (exept in IE8; I tried Chrome 17, IE8, FF10.0)

this is the UiBinder source code:

<gxtForm:Radio readOnly="true" boxLabel="M" />
<gxtForm:Radio enabled="false" boxLabel="M" />
<gxtForm:Radio readOnly="true" enabled="false" boxLabel="M" />

And this is the result


<div id="x-widget-39" class="GJV4SYICLK" __gwtcellbasedwidgetimpldispatchingfocus="true" __gwtcellbasedwidgetimpldispatchingblur="true">
<div class="GJV4SYICMO">

<input id="x-auto-0" type="radio" name="" readonly="">

<label class="GJV4SYICGO" htmlfor="x-auto-0" for="x-auto-0">M</label>

</div>


</div>

<div id="x-widget-40" class="GJV4SYICLK GJV4SYICFK" __gwtcellbasedwidgetimpldispatchingfocus="true" __gwtcellbasedwidgetimpldispatchingblur="true">
<div class="GJV4SYICMO">

<input id="x-auto-1" type="radio" name="">

<label class="GJV4SYICGO" htmlfor="x-auto-1" for="x-auto-1">M</label>

</div>
</div>

<div id="x-widget-41" class="GJV4SYICLK GJV4SYICFK" __gwtcellbasedwidgetimpldispatchingfocus="true" __gwtcellbasedwidgetimpldispatchingblur="true">
<div class="GJV4SYICMO">

<input id="x-auto-2" type="radio" name="" readonly="">

<label class="GJV4SYICGO" htmlfor="x-auto-2" for="x-auto-2">M</label>

</div>
</div>


How should I really disable it?

koenjan
28 Feb 2012, 7:25 AM
is this the same error as in
http://www.sencha.com/forum/showthread.php?181111-disabled-spinner-can-still-be-changed-with-up-down-buttons-amp-edited ???
and therefore fixed in SVN?

WesleyMoy
1 Mar 2012, 9:05 PM
This does seem to be fixed in Beta 4 (http://www.sencha.com/forum/showthread.php?184556-Ext-GWT-3.0-Beta-4-Now-Available). The latter two radio buttons become disabled. Try your test case with Beta 4 again and post a reply if you still notice any problems.

koenjan
2 Mar 2012, 12:05 AM
Yes, it is fixed in beta 4... thank you guys! Keep up the good work!