PDA

View Full Version : [FIXED] (beta3) Inconsistent getter naming in BarSeries



lefke123
28 Feb 2012, 7:08 AM
Some method namings that can be found throughout chart classes:

Axis.getX()
Axis.getY()
BarSeries.setXAxisPosition(...)
BarSeries.setYAxisPosition(...)
BarSeries.addYField(...)
BarSeries.removeYField(...)

But in the BarSeries class there are the following methods that aren't conform (AFAIK):

BarSeries.getyField(...)
BarSeries.getyFields()

IMHO they should be renamed to:

BarSeries.getYField(...)
BarSeries.getYFields()

It's a very small thing, but I just wanted to let you guys know.

BrendanC
28 Feb 2012, 5:46 PM
Thanks for pointing that out. Will be fixed in the next release.