View Full Version : Installing and running SenchaSDKTools-1.2.3 (64 bit) on Ubuntu 11.10 x64 problems

4 Mar 2012, 5:58 AM
So, i was trying to install SDKTools 1.2.3 (64bit) on my fresh Ubuntu 11.10 x64 install. And i ran into a problem. if i tried to run

sencha build -p app.jsb3 -d .

i always got an error

bash: /home/.../SenchaSDKTools-1.2.3/jsdb: No such file or directory

in the end i found out that jsdb is 32bit and you need to do

sudo apt-get install ia32-libs

and it should work ...

Also I installed/uninstalled SDK tools a lot of times and found out that the installer modifies



export PATH = PATH_TO_SDK/command:$PATH
export PATH = PATH_TO_SDK/jsbuilder:$PATH

but the uninstaller doesnt clean it up. After you uninstall SDKTools everything stays there. If you try to install SDKTools in 2 different locations in just appends exports for the new version and in the end you have a very very long PATH variable

4 Mar 2012, 7:18 AM
Thank you for posting how you worked around your issues.