PDA

View Full Version : Grid with grouping and drag and drop



abcdef
7 Mar 2012, 5:17 PM
I have a grid with drag and drop enabled. It also makes use of grouping. Very simple - follows mostly what the examples show.

Lets say I have the following:

Grids A and B
Groups X and Y in each of the grids

When I drag a record from (Grid A, Group X) to say an empty Grid B, the record gets grouped under Group X in Grid B. All well and good here.

When I take this record from (Grid B, Group X) and drop it under (Grid A, Group Y), the record automatically places itself under Group X as expected. All well and good here.

The problem is when at this point, I try to drag this record from (Grid A, Group X) to say an empty Grid B, after the drop on Grid B, I see that the record that I dropped was in fact not the one that I dragged - its some other random record in Grid A under Group Y. In other words, the record that I initiated drag on, remains in the original grid, and a record completely different from the one I was expecting actually gets dropped.

Hopefully this makes sense. I tried playing around with giving the same/different grouping feature IDs to these grids but this problem persists.

Can someone help me here? It might just be some configuration issue - I don't know. But I can provide code if need be. Does this problem sound familiar?

mitchellsimoens
8 Mar 2012, 4:30 PM
What Ext JS 4 version? This sounds like a bug that was fixed where the index values of the records weren't being updated causing the record you move around not be the one that is being viewed.

abcdef
8 Mar 2012, 5:43 PM
I am using 4.0.2a. Is this a version you think is affected?

mitchellsimoens
9 Mar 2012, 5:10 AM
Very much so.

abcdef
12 Mar 2012, 1:52 PM
Ok Thank you. I tried using 4.0.7 and now the grid masks don't show up while the store loads. This used to work flawlessly in 4.0.2a. I'll write up another thread. Thanks!