View Full Version : Unable to create jsb3 file on Windows XP

7 Mar 2012, 7:30 PM
I tried to use sencha create jsb -a index.html -p app.jsb3 command to build jsb from my index.html. There is no response after the command, only a line break was displayed. No jsb3 file was generated in my destination folder. I was puzzled at the time. So I went to try the example of Getting Started with Ext JS. I had exactly same code from the tutorial, the code ran in browser properly but Sencha SDK Tool still wouldn't build anything.

I came back from work to home and tried again on my Mac, and it worked perfectly. I don't know why this has occurred at all. I'm willing to share the code I tried on Github if it's necessary.

Is there any way for SDK tool to give out more stack trace and error messages when there is some trivial error like wrong path or missing a comma. It really doesn't produce anything if some config is wrong so there is no way to know whether this is a config fail or js runtime error.

I also experimented with sencha package command with Sencha Touch. There is a weird problem building for iOS at the moment, please check here if interested: http://www.sencha.com/forum/showthread.php?185744-Unable-to-package-iPhone-native-app-on-Mac-source-path-is-nil

8 Mar 2012, 2:27 PM
SDK Tools 2 Beta for Windows is having issues we are working through.

8 Mar 2012, 2:59 PM
Nice! Keep up the good work!
Keep me posted when it's all worked out. \:D/

12 Mar 2012, 6:14 AM
You can try this, I'm using windows 7 64bit, worked for app.
http://www.sencha.com/forum/showthre...ionality/page4 (http://www.sencha.com/forum/showthread.php?182883-Sencha-Windows-SDK-Tool-2.0-Beta-Missing-Functionality/page4)