View Full Version : sencha SDK Tools accesing problem (WIN 7)

8 Mar 2012, 11:01 AM
I installed Sencha SDK Tools on 2 different computers.

First PC: Win7 64 bits and when i type sencha it says ... was unexpected at this time (see image below)


What im missing here?


8 Mar 2012, 11:05 AM
Well, I type: cd SenchaSDKTools-2.0.0-Beta\bin them "sencha" and it works.

What i was missing is that i need to go to the directory and them type sencha

8 Mar 2012, 11:16 AM
I got another issue, when i type the create command it does nothing, theres not message telling me that the process is completed (the file isnt created), instead it leaves a random blank space.


What could i do.?


8 Mar 2012, 11:12 PM
Well, I had the same issue, unfortunately the Docs never say to go to the SDK folder before typing Sencha...
Maybe that this is logical for most of you, guys, but for me, as a beginner...

Anyway (and I think this relates to your second question), aren't we supposed to cd ourselves to the Sencha folder with the index.html???
Because, when I do that, Sencha doesn't work anymore!

Also, on Windows 7 64bit, is there a prefered folder for installing "Sencha SDK Tools"? I noticed everyone installs directly to a folder on C:, whereas the installer would rather install it in Program Files...

9 Mar 2012, 1:03 AM
I found my answer to this error: "\SenchaSDKTools-2.0.0-Beta\bin\ was unexpected at this time"
In this thread:

Seems in Win7 64 bits, you should NOT install SDKtools in "Program Files(x86)". Change install path to "Program Files" or something else..

18 Apr 2012, 7:41 AM
I recently installed sencha SDK tool using SenchaSDKTools-2.0.0-Beta-windows.exe, which was installed under "C:\Program Files\Sencha" .

I read the posts from the thread , but none of the solution worked from me .

The screen shot for the problem I am face is as follows:

After installing the SDk I tried to create an app as per the "getting started video".

can anyone please suggest solution for the problem. Thanks.
Let me know if I'm doing anything wrong. My system runs Windows 7 X64 bit Home Premium edition

18 Apr 2012, 11:04 AM
many guys encountered the same problem:
http://stackoverflow.com/questions/10009159/deployment-wont-work-with-sencha-sdk-tools (http://www.sencha.com/forum/showthread.php?195038-quot-sencha-create-*-quot-don-t-work-but-no-error)