View Full Version : No Output from SDK Tools

10 Mar 2012, 4:21 AM
I'm trying to follow Ed's new video tutorial "Getting Started with Touch 2" and when I run the very first command in the video (i.e. sencha generate app GS ../GS). It runs quickly but nothing happens.

If I run the sencha command in Terminal I get a list of the available commands, however if I run sencha [command], (e.g. sencha app or sencha generate) I get no output.

I have installed the latest SDK and SDK Tools.

Is there something I'm doing wrong?

PS. I'm using a new Macbook Pro setup specifically for Sencha Touch.

10 Mar 2012, 9:22 AM
From what I can tell it's a bug with the SDK tools in Windows.

I'm also new to Sencha. Anyone experienced know a way around this us new people could use?

Perhaps generate all those files for us and make them available. I know the example is in the docs but I want to start from the start to learn.

12 Mar 2012, 3:22 AM
When typing 'sencha' at the cmd prompt ...I get

Sencha Command v2.0.0 Beta
Copyright (c) 2012 Sencha Inc.

usage: sencha COMMAND [ARGS]

The available commands are:
build build a JSB project
create bootstrapdata generate boostrap data
create jsb generate a minimal JSB project for an app
create locale generate a template locale file from source
create manifest generate classes manifest
package package your Touch web app into a native bundle
slice theme slice a custom theme's images for IE


as expected, when typing "sencha app create MyApp /usr/local/apache2/htdocs/myapp" or even "sencha app create MyApp /usr/local/apache2/htdocs/myapp", nothing happens...

I've downloaded the latest version of the SDK (SenchaSDKTools-2.0.0-Beta-osx) & libraries (sencha-touch-2.0.0-gpl.zip) and installed as documented. I am doing something wrong here?


13 Mar 2012, 3:17 PM
I'm having the exact same problem.

13 Mar 2012, 11:13 PM
I got it working ...

I typed "sencha app create MyApp /usr/local/apache2/htdocs/dev.2/myapp" in the directory in which I unzipped the library files (sencha-touch-2.0.0-gpl.zip). NOTE: NOT the SDK (although that IS installed too!). In my case the location for installing the library files is "/usr/local/apache2/htdocs/lib.2/".

So basically ...

cd /usr/local/apache2/htdocs/lib.2/
then ..
sencha app create MyApp /usr/local/apache2/htdocs/dev.2/myapp

Note: I'm on a Mac ...

Hope this helps someone out there.


14 Mar 2012, 1:04 AM
Oh I see. This was not very clear from the video tutorial (http://www.sencha.com/learn/getting-started-with-sencha-touch-2/). So you need to cd into the Sencha Touch SDK and run the create command from there and not from the Sencha SDK Tool (the Sencha SDK Tools just needs to be installed somewhere on the computer).

Now this tutorial (http://docs.sencha.com/touch/2-0/#!/guide/command) makes more sense (although it says sencha-touch-2-sdk I didn't get it B) ).


14 Mar 2012, 1:15 AM
No worries, hope it lead you on the right track :D

19 Mar 2012, 11:56 AM
But there is another issue on Windows. It shows following error even if I follow instruction in this thread.

\SenchaSDKTools-2.0.0-Beta\bin\ was unexpected at this time.

I read in other thread, this might be bug in SDK on 64 bit machine. ( I have 64 bit ).


22 Mar 2012, 6:17 AM
I have tested on win xp too and then we have the same problem!
After test on OSX Lion 64bits I have tried on Win XP over virtual box.


22 Mar 2012, 10:02 AM

Fallow that steps to make works SDK + Tools.

First you must download sencha touch sdk and sencha tools ( and install then by the way).
on command line enter on directory of your uncompressed sdk.
and finally you can do all the commands like we see in gs tutorial


22 Mar 2012, 11:55 PM

6 Apr 2012, 4:47 PM
it turns that the sencha touch SDK, (NOT the SenchaSDKTools) has its OWN COPY of sencha command that behaves completely differently.

If you look in the SDK there is a folder 'sencha-touch-2.0.0-gpl/command' that is a replacement to what's in the SenchaSDKTools ( 'SenchaSDKTools/command' ).

But you need all the rest of the stuff that's in 'SenchaSDKTools'. (confused yet? I know I am)

so there is a magic, ugly, hook that checks if the CURRENT folder has an override of the /command (it looks for a file like '.senchasdk') and then seems to do the right thing.

This is all really messy, and needs a cleanup, or better documentation