PDA

View Full Version : css not compiling with new versions of sass



dkeegan
15 Mar 2012, 6:05 PM
Hey guys,

We've been using sass 3.1.1 and compass 0.11.1, however I recently updated these gems to the latest versions(sass 3.1.15 and 0.12.1) and we can no longer build our custom css. This is with Ext 4.0.7.

Here are the types of error I'm seeing when we try to compile the Ext sass:

DEPRECATION WARNING:
On line 1 of "", after "&"
Starting in Sass 3.2, "-over" may only be used at the beginning of a selector.


DEPRECATION WARNING:
On line 1 of "", after "&"
Starting in Sass 3.2, "-menu-active" may only be used at the beginning of a selector.


DEPRECATION WARNING:
On line 1 of "", after "&-menu-active, &"
Starting in Sass 3.2, "-pressed" may only be used at the beginning of a selector.

...

error Source/client/theme/sass/ext.sass (Line 115 of _frame.scss: Functions may only be defined at the root of a document.)

jsakalos
15 Mar 2012, 10:31 PM
I've read somewhere on the forums the specific versions with what Ext works. Anyway, I can move this post to Bugs forum if you want to notify the developers on the matter.

dkeegan
19 Mar 2012, 11:56 AM
Whichever is best for finding out the 'approved' versions or when an update will be coming to make the Ext sass compatible with current versions of sass and compass.

jsakalos
19 Mar 2012, 12:02 PM
Would this (http://docs.sencha.com/ext-js/4-0/#!/guide/theming) help?

dkeegan
19 Mar 2012, 12:57 PM
I don't see any mention of which version of sass and compass Ext is compatible with.

jsakalos
19 Mar 2012, 9:28 PM
OK, moving the thread to Bugs.

dkeegan
14 May 2012, 1:48 PM
Any word on this?

burnnat
15 May 2012, 8:03 AM
This has been fixed in ExtJS 4.1.0. If you need it to work in 4.0.7, there are some diff patches listed in this thread (http://www.sencha.com/forum/showthread.php?158358-4.0.7-Syntax-errors-when-compiling-SASS-themes&p=706963&viewfull=1#post706963) that you can apply. (Or, of course, you could also downgrade the version of SASS you are using.)