PDA

View Full Version : ExtJS Combobox and Datagrid Scroller issue



Shehul
28 Mar 2012, 10:52 AM
Hi,

I have a combobox with Select event.

I have a grid whose store is getting loaded by the combobox selected value.

Anytime I change the value of combobox my grid should reload because I am reloading the entire store.

This is working as expected and as mentioned.

However I have a scrollbar with the grid and for some reason after 3 to 4 loads(after changing 3-4 times the combobox selection and loading gridstore again) the scrollbar stops working.

I see the scrollbar is there , I can move that in the grid ,but moving the scrollbar doesn't scroll my data.

Please reply if this is a bug in ExtJS scrollbar or I am doing something wrong.

Thanks,
Shehul

mitchellsimoens
28 Mar 2012, 11:21 AM
What Ext JS 4 version?

Shehul
28 Mar 2012, 11:39 AM
Its 4.0.7 GPL.

What Ext JS 4 version?

mitchellsimoens
28 Mar 2012, 11:39 AM
4.0.x was plagued with scrolling issues that 4.1.0 has fixed (almost all that I hav eseen)

Shehul
28 Mar 2012, 11:44 AM
Hi mitchellsimoens,

I have no problem in updating to 4.1.0 except that when I downloaded the files for 4.1.0 , I am missing bootstrap.js file.

I still changed my link of 4.0.7 to 4.1.0 extall.js file, but I am getting following error,

__field3 is undefined (46 out of range 18)



I am not sure what it mean and what is wrong in my existing code which breaks in 4.1.0

Please reply,

Thanks,
Shehul













4.0.x was plagued with scrolling issues that 4.1.0 has fixed (almost all that I hav eseen)

Shehul
28 Mar 2012, 12:15 PM
Further I found in updating to Ext 4.1.0 and using extcore.js
my store load is giving that error of __field3 is undefined
and this is working in 4.0.7.
Can you please guide if the store load call was changed in 4.1.0 and if it was, what is the new way to load store with parameter based proxy.

Thanks,
Shehul


Hi mitchellsimoens,

I have no problem in updating to 4.1.0 except that when I downloaded the files for 4.1.0 , I am missing bootstrap.js file.

I still changed my link of 4.0.7 to 4.1.0 extall.js file, but I am getting following error,

__field3 is undefined (46 out of range 18)



I am not sure what it mean and what is wrong in my existing code which breaks in 4.1.0

Please reply,

Thanks,
Shehul