PDA

View Full Version : Ext JS 4.0.7 to 4.1.0 Upgrade issue



Shehul
29 Mar 2012, 7:32 AM
Hi,

This is in reference to my earliar thread for ,

http://www.sencha.com/forum/showthread.php?191550-ExtJS-Combobox-and-Datagrid-Scroller-issue

As suggested by mitchellsimoens, I need to update my ExtJS version from 4.0.7 to 4.1.0 to solve the issue.

My issue in upgrade are,

1) I downloaded the Ext 4.1.0 but there is no bootstrap.js. Where to find this and if this has been eliminated in new version what are the things needed to change in the code.

2) I changed my code to use the Extall.js instead of bootstrap.js but its giving me following error (as seen in firebug),

__field3 is undefined (46 out of range 18)

Please let me know what are the changes I need to do in order to successfully run my working code of 4.0.7 to version 4.1.0.
In my code I have grid,Datastores,Combobox,Timer and Ajax proxies using XML as well as JSON.

Please reply urgent, I am stuck with the scroller issue and to solve I need to update my ExtJS.

Thanks,
Shehul






(http://www.sencha.com/forum/showthread.php?191550-ExtJS-Combobox-and-Datagrid-Scroller-issue)

mitchellsimoens
29 Mar 2012, 8:07 AM
All bootstrap.js did was write out a <script> tag and determine whether it should use ext-all.js or ext-all-debug.js.

Shehul
29 Mar 2012, 8:46 AM
Hi mitchellsimoens,

I am not sure I understood your comments, you mean to say I can use Extall.js instead of bootstrap.js and if so than why am I getting the error?

Please reply...

Thanks,
Shehul


All bootstrap.js did was write out a <script> tag and determine whether it should use ext-all.js or ext-all-debug.js.

Shehul
29 Mar 2012, 11:36 AM
The issue was one extra comma in my data model not sure why all these days 4.0.7 never failed.