PDA

View Full Version : help need regarding application build using sdk tools



extremed
31 Mar 2012, 8:48 AM
Hi

im trying to build a application and it seems to be working fine but once build is complete

all-classes.js and app-all.js are same size and app-all.js not compressed, even though i have this output on command prompt



D:\>sencha build -p app.jsb3 -d .
Loading the Project Name Project
Loaded 0 Packages
Loaded 2 Builds
* Parse all-classes.js with options:
- debug: true
- debugLevel: 1
* Parse app-all.js with options:
- debug: false
- debugLevel: 1
* Compress and obfuscate app-all.js...
Copy resources...
Done building!

maybe compress depend on the size of all-classes.js file ?

so i included the app-all.js + ext.js + app.js in my index file and once the project loads i still see these file are loading once the application is launch

33389

any idea why app-all.js file is not compressing and those file loads once application is launch?

Regards

mitchellsimoens
31 Mar 2012, 8:56 AM
The files are still loading because you haven't required them to be loaded so they weren't picked up when you created the JSB.

extremed
31 Mar 2012, 9:07 AM
any idea why the file not compressed?

vietits
31 Mar 2012, 3:47 PM
I myself encountered this problem sometimes. However, it was OK if I ran the same sencha build command the second time. I didn't know why.
One thing you should check your app.jsb3 is making sure compress is set to true for the app-all.js target. This is default setting when creating jsb file.

extremed
31 Mar 2012, 10:24 PM
ya compress is set to true.

i notice that if all-classes.js file is less than 2mb compress seems to be working but not over 2mb.

any one notice that?

vietits
1 Apr 2012, 12:17 AM
In my case, all-classes.js is around 3.65MB, and compressed app-all.js is around 0.87MB.

extremed
1 Apr 2012, 12:30 AM
maybe bug in sdk tools or its not support windows ?

i use windows 7 ultimate 64bit and SenchaSDKTools-1.2.3

vietits
1 Apr 2012, 12:51 AM
I use SenchaSDKTools-1.2.3 on Windows 7 32 bit.