View Full Version : Android browser can't refresh the application

8 Apr 2012, 9:22 AM
I've created an app and upgraded several versions using the sdk and successfully deployed it on my server. Everything works fine with Chrome, Safari (iPad, iPhone), except with my Sony Xperia which is stuck in an endless loop of 'attempt to refresh the application' pops-up.

Requested: 'http://(mysite)/app.js' with checksum 2fe76(...).434 but received: t.define("Ext.event.ListenerStack",{cu instead. Attemp to refresh the application

Acknowledging or canceling the update doesn't make any difference. I'm using the browser shipped with Android 2.3. Is there a known issue with the microloader on this device browser?

Jacky Nguyen
8 Apr 2012, 8:35 PM
Can you paste the first ~ 50 characters of your production build's app.js here? Also, upgrade your app to SDK 2.0.1-RC by following this thread (http://www.sencha.com/forum/showthread.php?192169-Important-SDK-Tools-Sencha-Command-Update).

8 Apr 2012, 11:25 PM
Here is the beginning of the app.js file:


I'll go through the upgrade steps and let you know if things improve.

Jacky Nguyen
8 Apr 2012, 11:43 PM
After upgrading both SDK and SDK Tools, replace your /path/to/your/app/sdk/microloader/production.js file with this: http://dl.dropbox.com/u/4494139/production.js.zip

Let me know if it solves the issue.

9 Apr 2012, 1:35 AM
I didn't get any luck. I've made several attempts without success:
- First try: upgrade SDK and SDK tools + upgrade my app + use the new production.js file and redeploy
- Second try: create a new app with the new SDK commands, copy my MVC files into the new app, and redeploy
- Since I modified the app.json to make full updates rather than delta, I've tried both configs (delta and full), but it has no impact on the browser behavior.
- Last try: I've reset the localstorage of the browser to start from scratch but same issue

To rule out any issue with my code, I've even created a new app with the SDK and deployed the production build without any modification and the Xperia experiences the same endless loop trying to refresh the 3 app files (app.js, app.css, sencha-touch.js).

Something is definitely wrong with this device.

Jacky Nguyen
9 Apr 2012, 1:41 AM
Have you tried to restart the device? Also try to deploy the app to a difference URL. Normally this happens when the browser app caches the assets and just doesn't clear it properly.

9 Apr 2012, 2:07 AM
Jacky, yes I've tried rebooting the device and deploying under a new domain.

I confirm that my Xperia is not able to load the default app generated by the SDK. I would be happy to point my device browser to one of your server so you can check why this is happening.

Jacky Nguyen
9 Apr 2012, 2:20 AM
How about the KitchenSink example: http://dev.sencha.com/deploy/touch/examples/production/kitchensink/

9 Apr 2012, 3:07 AM
The kitchen sink app works (at least).

The issue seems to be around the SDK for Mac (which I'm using). I've done the following test:
- produce a production build of one of the SDK examples:
cd/mysdk/sencha-touch-2.0.1-rc/examples/carousel; sencha app build production
- copy the deploy folder under my apache (I've tested even 2 hosting servers)
- connect with the device which enters into the loop

This means I'm not able to create a production build from the Mac SDK that works for this device (note that the non-production/debug build has no issue).

Has the kitchenSink app been built on Mac?

9 Apr 2012, 8:35 AM
I've eventually nailed down the problem. Good news is Sencha is not guilty. My 3G provider is.

The Xperia was actually the first device I tested over 3G and didn't notice my app was working properly over Wifi.

It turns out that Vodafone is using a transparent proxy that automatically compresses contents and removes comments (so the version is missing from all the production files). I've enabled gzip on my web server to avoid Vodafone messing the javascript files and it now works.

This was a tough one...

Jacky Nguyen
9 Apr 2012, 1:08 PM
It's good to know!

1 May 2012, 10:19 AM
For the record I am experiencing a similar problem. My client can run the 'production' app on WiFi but when they switch to 3G they get a similar sequence of errors. However, when I connect to their server with my iPhone it works no problem. The only difference is that I am on '3' (UK network) and my client has been testing on O2 and T-Mobile.

We will try and install gzip on IIS and report back

2 May 2012, 1:25 PM

11 Sep 2013, 6:55 AM
I have the same problem, but when trying to open the production build of the site in any browser on the desktop.

The message is:

The page at localhost:8888 says:

Requested: 'http://localhost:8888/app/config/Constants.js' with checksum: 0ad530f24957f6ea33ac4320beb79f4928c778ce but received: 0ad1030f249107f6ea33ac4320beb79f4928c7instead. Attemp to refresh the application?

Looking at the checksums, the first one has two 5's where the second one has two 10's. The second one has the last 4 digits chopped off in the message.

The actual Constants.js file that has been generated starts with:


This happens in Chrome, IE and Safari. I have tried clearing the cache completely, re-installing the web site to a different port, enabling Dynamic Content Compression in IIS, but none of these steps have worked.

I am using Sencha SDK Tools to build the production files, as the code base of the application is using Sencha Touch 2.0.0.

Any ideas?

11 Sep 2013, 7:05 AM
OK I just tried rebuilding the production files (sencha app build production) and now it works fine. Any ideas what might cause this to occur?

11 Sep 2013, 7:31 AM
OK I think I know what the problem is now, it is a different issue to this thread now so new question here: