View Full Version : [FIXED] Deploy does not complete

17 Apr 2012, 8:11 AM
Now running Architect (congrats on the GA release!)

When I click deploy, it pops up a box that says "running xcopy ...." with a blank white box and a close button.

Never updates or goes away.

Windows 7 64-bit, Architect 2.0

Any thoughts?

17 Apr 2012, 8:19 AM
Could I get a screenshot? This is what my win7 64 bit looks like


I just started a super simple project, saved it, configured a deploy path and then deployed.

17 Apr 2012, 8:30 AM
Hi Aaron,

I get same results with existing project and new "empty" project. It never moves from this screen, and I can confirm that the referenced exclude.txt is being created and appears reasonable.

Directories referenced also exist. This was working just this morning before the changeover to Architect.

Thanks for any help.


17 Apr 2012, 8:34 AM
Hi Aaron,

The difference I saw was you did not have spaces in your directory/file name and I did. Resaved project into different directory and it now deploys fine.

Might want to look at delimiting the paths on the xcopy command.


17 Apr 2012, 8:38 AM
Yup, looks like quoting or escaping them will fix this issue.

Thanks for the bug report. We'll be issuing a patch release that ties up some small (and safe) bug fixes in the next day or two. This should be in that.

17 Apr 2012, 3:53 PM
I came across this bug too after upgrading my old build of the beta to Architect 2. The reason I was running an old build was because it couldn't update itself (due to proxies). Will the new version cope with being behind a corporate proxy server (over which I have no control), and if not, will I be able to download the latest/updated installers myself when bugs are fixed?

The installer for Architect allowed me to successfully configure a proxy to license the product, but now that it's licensed, I see no proxy settings dialogue box, so I would guess that Architect therefore won't be able to update itself, or even notify me of new updates if it has no proxying support?


17 Apr 2012, 8:11 PM
I wanted to confirm that on Windows 7 64-bit found a problem with path names having a space. I was able to correct by replacing the " " (space) with an "_" (underscore). Though this will probably not work for every use case.

17 Apr 2012, 11:37 PM
When we release a patch build, it will notify you on application start that there is an update available.

You will then have the option to Install or say Not Now.

19 Apr 2012, 2:48 PM
The beta was not able to do this (behind the authenticated proxy where I work) so has this been fixed in Sencha Architect?