PDA

View Full Version : Sencha Touch SDK Tools Integration



dmillasich
18 Apr 2012, 8:18 AM
I love the new architect IDE.

However, I'm confused about which version of the SDK tools to install in order to deploy to the simulator. I've downloaded the latest advertised SDK from the Sencha site, but there's an apparently more recent "patched" version that should be used instead.

When I purchase Sencha Architect 2 - it'd be great if the package included all of the required support libraries. When I buy a car - I (usually) don't have to go buy the tires separately. They're required in order for the car to be useful. I realize that Sencha Architect 2 is "usable" as is - but to be fully functional it requires the SDK tools. To learn this one needs only click on the "deploy" button in order to be met with a couple of disabled buttons.

...just a thought.

aconran
18 Apr 2012, 8:20 AM
Thanks for the feedback. We're working on the package/simulate experience.

Although I'm unsure that we will be able to couple the SDK tools with Architect, we'll certainly try to make this experience more fluid.

dmillasich
18 Apr 2012, 10:00 AM
fair enough. i can imagine there's a flurry of activity keeping up with everything surrounding a major release such as this one. it's a brilliant product, light years ahead of anything in it's class.

in the mean time, it would go a long way to provide definitive directions to the correct Sencha Touch 2 SDK with explicit instructions for setting up the environment so that packaging and simulating can be exercised.

thanks for this tool. even without the above, it does so much that i can't possibly afford to do without it.