PDA

View Full Version : Help with alignments



kencl
19 Apr 2012, 9:01 AM
I need some help to align a panel. I have a form which consists of 3 hbox sections, top, middle and bottom. Top and bottom are docked so they align fine, but the middle box doesn't align correctly. It is 20 or so pixels indented from the left. (screencap align1.png) I want it to align directly below the Cost fieldset. If I dock it to the left it aligns properly, but then it overlaps (hides) the bottom button! (screencap align2.png)

Suggestions? Thanks.

kencl
19 Apr 2012, 10:12 AM
I found a way to move it to the left (and up a bit too) by setting the fieldsets top and left properties to zero. There's a bug, however, which causes all the data within the fieldset to be hidden, leaving only the title visible, when any value is set...

kencl
19 Apr 2012, 10:45 AM
I gave up on that and stopped docking the top fieldset.

bharatn
19 Apr 2012, 10:47 AM
Dont you want to use the vbox layout on the formpanel?

kencl
19 Apr 2012, 11:30 AM
I tried that, and a lot of other things. I think, really, that I should not have been docking the top fieldset.

bharatn
19 Apr 2012, 11:32 AM
Hi,

Are you saying your problem is resolved?

Could you shed more light on how to reproduce the bug - which causes all the data within the fieldset to be hidden, leaving only the title visible, when any value is set

Thanks

kencl
19 Apr 2012, 11:43 AM
The problem of alignment is resolved in that I am not trying to make the second box align with the first box.

I'm having the same disappearing panel problem with a different approach (see my other post (http://www.sencha.com/forum/showthread.php?196951-setting-scrollable-causes-container-to-vanish&p=784349)). Could be a problem with checkboxes being scrolled rather than anything to do with fieldsets.