View Full Version : SDK Tools not detected (Win7 / Touch 2.0 project)

25 Apr 2012, 9:28 AM
When I click to deploy a project, the popup window always says that the SDKTools v2 aren't installed, but they are. Am I missing out on functionality here? Is this an order of installation problem, in that Architect was (re)installed after the SDKTools v2 beta was in place?

26 Apr 2012, 3:31 AM
Try from the command line to execute "sencha" and see if it displays an error.

If you get "Error: \SenchaSDKTools-2.0.0-Beta\bin\ was unexpected at this time." then you're likely encountering this issue: http://www.sencha.com/forum/showthread.php?186053-Error-%5CSenchaSDKTools-2.0.0-Beta%5Cbin%5C-was-unexpected-at-this-time.

(http://www.sencha.com/forum/showthread.php?186053-Error-%5CSenchaSDKTools-2.0.0-Beta%5Cbin%5C-was-unexpected-at-this-time.)Hope that helps

26 Apr 2012, 9:05 AM
I just uninstalled (Win7) from its default path of "Program Files(x86)\..." and reinstalled to c:\Sencha. Now when I run sencha.bat, I get the following error:

'jsdb' is not recognized as an internal or external command,
operable program or batch file.

What is JSDB?

26 Apr 2012, 10:37 AM
Downloading JSDB from www.jsdb.org works. Here's what I had to do to get this working:

- Uninstall the tools
- Reinstall them into a “\Program Files” path or to a new path like “C:\Sencha”
- If you don’t have JSDB (JavaScript for Databases) installed, go to http://www.jsdb.org/ and download the latest package.
- Extract the JSDB zip file into a directory in your path (or install it anywhere and add that directory to your path)
- Open a command prompt
- Go into your new installation directory and then into the bin folder, which for me is “c:\Sencha\SenchaSDKTools-2.0.0-Beta\bin”
- Type ‘sencha ‘ to run Sencha.bat

26 Apr 2012, 8:54 PM
I'm sorry you had such trouble getting SDKTools installed. I was able to use the installer on my Win7 box and sencha command just worked.

27 Apr 2012, 9:05 AM
Clearly you're an expert in this matter, though. Just because it worked well for you doesn't mean that it's working well for everyone, especially those of us who are new to Touch.

Note that I'm on a 64-bit system, so the tools installed into a different directory than with a 32-bit system ('Program Files (x86)' instead of 'Program Files').