PDA

View Full Version : fieldset's title in multiple lines



ejml
25 Apr 2012, 11:38 PM
Hello,

I have a formpanel with two columns, each colums has a few fieldsets with titles, my problem is that the title of fieldset in FF is displayed in one line but in IE is displayed in multiple lines, it depends on the separation between workd (blank space). Is there some property to stop this behavior?

Thanks in advance

scottmartin
27 Apr 2012, 8:39 AM
Can you provide a screenshot with a bit more details?

Regards,
Scott.

ejml
22 Jun 2012, 12:13 AM
Sorry Scott,

I have been working in other projects. There is my problem, I have uploaded a image with the issue.

You can see to in firefox is right but in Iexplore 8 the tittle is inside of border fieldset and hte tittle fill two lines.

Thanks in advance

scottmartin
22 Jun 2012, 5:42 AM
Do you see the behavior with our online examples:
http://dev.sencha.com/deploy/ext-3.4.0/examples/form/check-radio.html

Can I get the version of ExtJS3 that you are using?
Do you have any custom CSS, or do you use ext-all-scoped.css?

Scott.

sword-it
22 Jun 2012, 7:43 AM
Hi,

Did you use nested fieldset, for example this fieldset is in another parent fieldset that has no border?

ejml
24 Jun 2012, 11:59 PM
Hi sword-it,

Yes, I have fieldset nested, I have enable all borders and it work fine, but I want disable some borders of parent fieldset, How I can do?.

Thanks in advance!!

sword-it
25 Jun 2012, 12:04 AM
Hi,

In ext-all.css file below lines breaks legend for nested fieldsets

/* IE legend positioning bug */
.ext-ie .x-fieldset-noborder legend {
position: relative;
margin-bottom:23px;
}
.ext-ie .x-fieldset-noborder legend span {
position: absolute;
left:16px;
}

you should try this one for your parent fieldset:
{
xtype:'fieldset'
//, border:false
, style:'border:none'
}
remove the border false property and add style as border:none.

ejml
25 Jun 2012, 12:35 AM
I have done this:

on the file ext-all.css:



/* IE legend positioning bug */
/*.ext-ie .x-fieldset-noborder legend {
position: relative;
margin-bottom:23px;
}
.ext-ie .x-fieldset-noborder legend span {
position: absolute;
left:16px;
}*/


In my scrypt:

var secondColumnFirstTab = {
style:'border:none',
xtype: 'fieldset',
....
};

Right?

sword-it
25 Jun 2012, 12:38 AM
No no, do not comment out these lines ext-all.css file, I have just written that lines to show you why it is broken.

Just remove border:false property from your parent fieldset and add style as border:none.

Do not remove or comment out anything from ext-all.css.

ejml
25 Jun 2012, 12:59 AM
Sword-it, very thanks, it worked as you said me.

Greetings!!