PDA

View Full Version : Extjs version 4.1.0 creating problems for the application developed in v 4.0.7



Sandeesh
16 May 2012, 7:15 AM
Hi,

We have developed an application using Extjs v 4.0.7.
We purchased a licensed version for Extjs (v 4.1.0).

When we try to integrate our existing app with this new licensed version,we are facing many problems.
For example : many of the components like viewport, panels, tab Panels aren't getting displayed.

Has anyone faced this issue.
It will be great if you can share the workarounds or options to get it integrated properly.

Thanks

jclark42796
16 May 2012, 7:56 AM
I can appreciate your frustration as we just upgraded from 407 to 410. FWIW, when we first upgraded, our panels didn't appear on our homepage. Found out that that it was the way that our layout was specified. This was code that carried over from 3.3 and worked in 4.0.7, but stopped working in 4.1.0 Our main panel had a vbox layout and we just said layout: 'vbox'. Once we switched to the following code, all was happy:


layout:{
type: 'vbox',
align: 'stretch'
}


Other items that involved UI rendering problems.

Grouptab panel: our items were a nested array, we had to flatten the array for it to work. Same thing in the case of a toolbar where items happen to be a nested array. These both worked in 4.0.7.

Ran into an issue where the order of beforerender and beforeactivate grid panel events changed. Posted a forum question but never got a response to whether this was intentional.

Unfortunately, there's no quick solution, you just have to start tackling each problem one by one. The forum is very helpful if you are able to post code snippets demonstrating what's not working.

Good luck,
Jim

scottmartin
17 May 2012, 9:34 AM
Another item that may be of help, use ext-all-dev to display warnings in the console.

If you have specific problems, please provide small working examples that we can review.

As Jim mentioned, it is most like a simple case of changing a setting.

Regards,
Scott.