PDA

View Full Version : Char is NOT displayed with IE8



MikiY
27 May 2012, 10:16 PM
Chart is NOT displayed with IE. I have copied a sample code for a chart from your document page and paste it into a simple HTML page.
With other browser it displayed well. What can I do with the problem?
IE Version: 8.0.7600.16385
ExtJs 4.1

My Code is;



<html>
<head>
<title>Task Man</title>
<link rel="stylesheet" type="text/css" href="{*Url.Root}ResourceGet/?file=extjs-4.1.0/resources/css/ext-all.css" />
<script type="text/javascript" src="{*Url.Root}ResourceGet/?file=extjs-4.1.0/ext-all-debug.js"></script>
<!-- Application JS -->


<script language="JavaScript">
<!--
Ext.onReady(function() {


var store = Ext.create('Ext.data.JsonStore', {
fields: ['name', 'data1', 'data2', 'data3', 'data4', 'data5'],
data: [
{ 'name': 'metric one', 'data1':10, 'data2':12, 'data3':14, 'data4':8, 'data5':13 },
{ 'name': 'metric two', 'data1':7, 'data2':8, 'data3':16, 'data4':10, 'data5':3 },
{ 'name': 'metric three', 'data1':5, 'data2':2, 'data3':14, 'data4':12, 'data5':7 },
{ 'name': 'metric four', 'data1':2, 'data2':14, 'data3':6, 'data4':1, 'data5':23 },
{ 'name': 'metric five', 'data1':27, 'data2':38, 'data3':36, 'data4':13, 'data5':33 }
]
});


Ext.create('Ext.chart.Chart', {
renderTo: Ext.getBody(),
width: 500,
height: 300,
store: store,
axes: [
{
type: 'Numeric',
grid: true,
position: 'left',
fields: ['data1', 'data2', 'data3', 'data4', 'data5'],
title: 'Sample Values',
grid: {
odd: {
opacity: 1,
fill: '#ddd',
stroke: '#bbb',
'stroke-width': 1
}
},
minimum: 0,
adjustMinimumByMajorUnit: 0
},
{
type: 'Category',
position: 'bottom',
fields: ['name'],
title: 'Sample Metrics',
grid: true,
label: {
rotate: {
degrees: 315
}
}
}
],
series: [{
type: 'area',
highlight: false,
axis: 'left',
xField: 'name',
yField: ['data1', 'data2', 'data3', 'data4', 'data5'],
style: {
opacity: 0.93
}
}]
});





});


//-->
</script>
</head>
<body>
</body>
</html>

scottmartin
29 May 2012, 11:20 AM
This displays for me fine:

35721

Regards,
Scott.

MikiY
30 May 2012, 7:44 PM
Hi scott,
Thank you for your reply but the link of your attachment is broken.
What do you think there are any IE settings or code issue?

- Sorry, Now I could open the link. Thank you!

I can also mention when the page is opened, the chart is actually there because when I move mouse onto it Tips are displayed so Chart is there but not visible.

Regards,
Miki

scottmartin
31 May 2012, 4:25 AM
35789

Trying attachment again.

Scott.