PDA

View Full Version : Compatibility IE



MaryRosy
11 Jun 2012, 2:30 AM
Hello everyone, I have a problem, I can not understand why the animations done with Animator can not view them with Internet Explorer. Who can help me please?

arnebech
11 Jun 2012, 9:57 AM
IE is not yet supported. We might start supporting IE10 once it is final.

MaryRosy
12 Jun 2012, 12:02 AM
Thanks for your answer .. but for now I can not do anything? add libraries, lines of code, nothing to see something in IE?

arnebech
12 Jun 2012, 7:18 AM
Yeah, CSS3 animations are not supported in IE at the moment. If you need to animate something in IE, you 'll probably have to create JS animations by hand, there might also be some libraries out there as well for that purpose.

vigom
21 Jun 2012, 11:00 AM
It may be work if you find the way to translate from html5 to flash, or css3 animations to flash.
Just came with the idea reading the post...

It is being a few weeks since I try S.Animator and it was very good application, however without ie support still not ready for work.

Great job with app!

vigom
24 Jun 2012, 1:51 AM
I wonder if Modernizr or Polyfill could help in some how to find ie compability.
I am not a programer so it maybe silly question.
Thank you for your time.

arnebech
25 Jun 2012, 7:30 AM
You might be able to find some polyfills that will add some CSS3 capabilities to older IE versions, but I doubt you'll find one that is extensive enough to support Animator animations at this point.

paengels
22 Jul 2012, 6:00 PM
I think in part it depends on what version of IE you need compatibility with. IE9 has some web-kit parameters that I have had success manipulating.

Head of your project, put:


<meta http-equiv="X-UA-Compatible" content="IE=9">
<link rel="stylesheet" type="text/css" href="ie.css">


Select for Sencha to split files on export and select Firefox compatibility. Locate the style.css file and open it in an HTML editor. Do a global search for "'-moz" and replace with "-ms". Save this as ie.css in the same folder as style.css.

It will not render animations or actions as well as other browsers, but you will at least get IE 9 support.

roseg
16 Jan 2014, 6:22 PM
Hi!

I am new in Sencha. I just want to ask if I will add the line that you said in app.html file's header:

"<meta http-equiv="X-UA-Compatible" content="IE=9">
<link rel="stylesheet" type="text/css" href="ie.css">"

will solve my issues in buttons and other components' appearance with IE browser, at least in IE 9?
Together with replacing the -moz with -ms in styles.css and saving it as ie.css. :s:-/

Your confirmation is greatly appreciated.

Thanks!

paengels
16 Jan 2014, 7:21 PM
Hi there! Yes, that allowed me to get more than a white screen in IE 9 and for basic interactions and animations to work. IE 9 will not look as great as other browsers, but that worked well enough for me that I was able to use it in a product I built for an international client.

cabbas
17 Jan 2014, 11:10 AM
Hi there,

Does this mean that IE 10 is now supported? Or, would you guys say that it's not recommended to develop css animations for IE at this time?

Thanks!

--

Oops, I found the answer, and the answer is YES:

http://www.sencha.com/forum/showthread.php?278557