PDA

View Full Version : How to determine correct Deploy Path in Architect with VS 2010?



jeisma
25 Jun 2012, 1:59 PM
I have a Web API project in VS2010 located:
C:\Users\Josh\Documents\Visual Studio 2010\Projects\InventoryManager

When I debug/run my project, Im sent to http://localhost:50670 (http://localhost:50670/) (every project uses a different port number)

So, I figured that I should set my deploy path the same as my Web API project. However, this does not work when I try to preview my ExtJS app while running my Web API.

Any suggestions?

scottmartin
25 Jun 2012, 3:51 PM
Your web application needs to be under webroot to run. You are directing it to a local DIR?

Scott.

jeisma
25 Jun 2012, 4:15 PM
Im directing it to a local directory because I want it to run on localhost.

When I run/debug my app from VS 2010, it opens up http://localhost:50670 (http://localhost:50670/). Similarly, I would like my ExtJS app (which uses the Web API), to run in the same instance, so I figured I should deploy the physical files in the same location my Web API is at.

scottmartin
25 Jun 2012, 5:34 PM
You are confusing localhost with local directory.

Localhost is an alias for 127.0.0.1, that is your local hosting .. this will load what is under you webroot.
Typically you would create a subdir under you webroot for your application/website.

so ... localhost/webapp/index.html
This is where you would setup virtual to point to this path when you enter your domain
name.

This is all separate from a local DIR on your hard drive.

in Windows, your webroot is c:\inetpup\wwwroot\ (this is where localhost will look)

Scott.