View Full Version : Can't generate example App

11 Jul 2012, 6:20 PM
[ERROR] Sencha SDK Tools 2.0.0-beta3 cannot be found from your system (SENCHA_SDK_TOOLS_2_0_0_BETA3 environment variable is not set). Please download and install version "2.0.0-beta3" of the tools from http://www.sencha.com/products/sdk-tools . Close this terminal and open a new one after the installation is complete.

While in the SDK directory after installing SDK Tools and typing sencha app create MyApp ../ I get the error above.

localhost:sencha-touch- scott$ senchaSencha Command v2.0.2
Copyright (c) 2012 Sencha Inc.

But sencha is installed? any help would be great. I've tried some of the suggestions in the forum already.

Lion 10.7

11 Jul 2012, 10:22 PM

have you seen this:-


12 Jul 2012, 5:10 AM
thanks for the thread link. I know have

export SENCHA_SDK_TOOLS_2_0_0_BETA3=/Applications/SenchaSDKToolsexport PATH=$PATH:$SENCHA_SDK_TOOLS_2_0_0_BETA3

in .bash_profile which appears to be the correct file for Mac 10.7

previously it had

export PATH=/Applications/SenchaSDKTools-2.0.0-beta3:$PATH

export SENCHA_SDK_TOOLS_2_0_0_BETA3="/Applications/XAMPP"

export PATH=/Applications/XAMPP:$PATH

both paths are correct at this point. I've installed the tools in two locations. it wasn't working prior to having it in two locations.

12 Jul 2012, 6:29 PM
I was using this with XAMP because I wanted something up and running quick. Installed MAMP again just something quick and now it works. just FYI for anyone in the future