View Full Version : ext-js 4.1.1 error after minification

7 Aug 2012, 2:36 AM
We were using ext-js 4.1.0 then upgraded to 4.1.1. Minification by using Sencha SDK tool were working properly for ext-js 4.1.0 but now after upgrade its giving following error. One more thing, without minification the application is working fine but we need to use minification as we have lot of js files. Appreciate your help in this regards.

Uncaught TypeError: Cannot call method 'substring' of undefined ext.js:18 (

Uncaught TypeError: Cannot call method 'getSelectionModel' of undefined app-all.js:4 (

clearYMMOpanelapp-all.js:4 (
Ext.define.onProjectsStoreLoadapp-all.js:4 (
fireext.js:18 (
Ext.define.continueFireEventapp-all.js:4 (
Ext.define.fireEventapp-all.js:4 (
Ext.define.onProxyLoadapp-all.js:4 (
Ext.define.processResponseapp-all.js:4 (
(anonymous function)app-all.js:4 (
Ext.apply.callbackext.js:18 (
Ext.define.onCompleteapp-all.js:4 (
Ext.define.onStateChangeapp-all.js:4 (
(anonymous function)ext.js:18 (

7 Aug 2012, 4:57 AM
Hi All,
Any one has any idea about this issue? Kindly let me know. Appreciate any help in this.


7 Aug 2012, 10:05 AM
I would use ext-dev in your dev and see if you have any hints that would denote what files you may be missing in requires, etc to cause this problem.


8 Aug 2012, 4:27 AM
Hi Scott,
Thank you for response. I tried with ext-dev.js but getting error as

Message: [Ext.createByAlias] Cannot create an instance of unrecognized alias: layout.tableview
Line: 7911
Char: 21
Code: 0
URI: http://localhost:7003/vl_web/gui/extjs/ext-dev.js

Message: 'Ext.getCmp(...)' is null or not an object
Line: 4
Char: 1497882
Code: 0
URI: http://localhost:7003/vl_web/gui/app-all.js

But here if I use ext-all-dev.js or ext-all.js then the application gets loaded properly, I don't know whether its right to change to any of these two files. Apprecaite right direction to resolve this.


8 Aug 2012, 5:26 AM
I am also facing similar issue.

8 Aug 2012, 6:35 AM
Since it works with 'all', it seems you have a missing requirement.

When you added ext-dev.js, did you run the application (uncompiled) and check the console for any hints? Was the console clear? Adding this to your compiled version will not help.


12 Aug 2012, 9:32 PM
I am facing similar issue.
We migrated from 4.1.0 to 4.1.1 since then we are facing below issue.
If we use ext-dev.js it's throwing below error.
But with ext-all.js it's working fine

Uncaught Error: [Ext.createByAlias] Cannot create an instance of unrecognized alias: layout.tableview ext-dev.js:7911
Ext.ClassManager.instantiateByAlias ext-dev.js:7911
Ext.define.statics.create Layout.js:54
Ext.define.getComponentLayout AbstractComponent.js:3021
Ext.define.setupProtoEl AbstractComponent.js:1408
Ext.define.constructor AbstractComponent.js:1078
Base.implement.callParent ext-dev.js:6207
Ext.define.constructor Component.js:334
constructor ext-dev.js:7307
Ext.apply.widget ext-dev.js:8393
Ext.define.getView Table.js:694

13 Aug 2012, 7:31 PM


before/outside your Ext.onReady or Ext.application call.

Or add
uses: ['Ext.view.TableLayout'] to the relevant class.

To know exactly what is going on and whether this is an Ext bug or not, you should provide more information on the involved components. Are you using Ext.tree.Panel, Ext.grid.Panel or maybe a component with a custom view class?

17 Aug 2012, 2:53 AM
Thanks It worked