PDA

View Full Version : My ExtJs4.0 framework and IE8 Browser Mode



seamas
14 Aug 2012, 1:34 AM
Hi,

I am using ExtJs4.0 and IE8.


Step1: I have added following meta tag in my jsp file.

<meta http-equiv="X-UA-Compatible" content="IE=8"/>

Then my IE8 dev tool show:
Browser Mode: IE8 Compat view .
Document Mode: IE8 Standards.

Step2: I found the folloing code in ext-debug.js file.


isIE7 = isIE && (check

/msie 7/) || docMode == 7),
isIE8 = isIE && (check(/msie 8/) && docMode != 7 && docMode != 9 || docMode == 8),

But My IE8 Dev Tool 'Browser Mode' still IE8 Compat view.

Could you please give me same suggest about this.

friend
14 Aug 2012, 5:09 AM
I generally don't set any compatibility meta tags in the page and rely on the framework to handle cross-browser compatibility.

seamas
14 Aug 2012, 5:26 PM
Could you please give some detail?

My IE8 Browser Mode always compatibility View Mode.
I want to IE8 standards Mode


Seamas

seamas
14 Aug 2012, 5:40 PM
Hi

When i am access to current site(http://www.sencha.com/forum/ (http://www.sencha.com/forum/newreply.php?p=871700&noquote=1)).
My IE8 dev Tool Browser Mode show : IE8 standards.
But my website always show : IE8 Compatibility view.


If there have ExtJs team member here, Could you please answer my question?

fschaeffer
14 Aug 2012, 9:55 PM
Just a quick quess: are you using an intranet server for your Ext application? If yes, there is a setting in IE (which by defult is on) to always use the compat view in intranet zones.

This setting is available at Extra -> compat settings -> and a checkbox like 'alway use compat view in intranet' (sorry only have a german version available).

As the sencha page is not in intranet zone IE uses the given doc-settings and switches to standard mode.

HTH

seamas
14 Aug 2012, 11:50 PM
Hi ,
Yes, My application is intranet.
I know IE8 have default setting "display intranet sites in compatibility view ".

But i want to my IE8 Browser Mode use IE8 standards not compatibility

Could you help me?

Seamas

.

burnnat
15 Aug 2012, 6:49 AM
The setting for "display intranet sites in compatibility view" takes highest priority in IE8 - there's no way to override it using page headers or meta tags. It's unfortunate that Microsoft designed it this way, but if you want the page to display in standards mode, you have to disable the "display intranet sites in compatibility view" option.

seamas
15 Aug 2012, 8:26 PM
Hi,
I changed ExtJs4.0 to ExtJs4.1, In IE8, when "Browser Mode" selected IE8 Compatibility View,
There have the same behavior as " Browser Mode" selected IE8 standards.

If there have no way to overide IE8 default setting 'disply intranet site in Compatibility view'.

Maybe update to ExtJs4.1 is the only way to avoid IE8 Compatibility Mode performance issue



se" "" 8 888888888