PDA

View Full Version : store not loading data



adeelmahmood
14 Aug 2012, 9:56 AM
for some reason i keep running into problems in trying to load data from different stores .. here is my model class



/*
* Issue.js
* Issue model class
* Used by Issues store class
*/
Ext.define("IP.model.Issue", {
extend: "Ext.data.Model",

fields: [
{name: 'id', type: 'string'},
{name: 'name', type: 'string'}
],

proxy: {
type: 'ajax',
url: selectorJsonPageUrl,
limitParam: '__pageSize',
pageParam: '__pageStart',
extraParams: {
__entType: '_Issue',
__entAttributes: '[["id","id"], ["name","name"]]'
},
reader: {
type: 'json',
root: 'results',
total: 'total'
}
}
});



and the response looks like this



{
"total": 3,
"results": [
{
"id": "com.webridge.entity.Entity[OID[8E58ED9C4E9E714D98E98636B47E189F]]",
"name": "task # 90 - Like the link to the bar chart - it could be useful; looks at the grants this PI has in the system - are the periods accurate? Is it just mocked up at this point?",
"customAttributes.problemDescription": "task # 90 - Like the link to the bar chart - it could be useful; looks at the grants this PI has in the system - are the periods accurate? Is it just mocked up at this point?",
"projects.*.id": ""
},
{
"id": "com.webridge.entity.Entity[OID[8E96C38192F45544A0A876188B65F5C0]]",
"name": "Personnel were allowed to be entered twice on an application",
"customAttributes.problemDescription": "<p>Validation rule was set on old first page view...with the 12/20/2008 patch, this was moved to view one so that duplicates cannot be added on submission.</p>",
"projects.*.id": ""
},
{
"id": "com.webridge.entity.Entity[OID[8EAFAD4301A55543A63CDA2C763B207E]]",
"name": "User can see study even though was removed due to lapse in required training",
"customAttributes.problemDescription": "<p><strong>Release to staging</strong></p>\r\n<p><strong>Development completed.&nbsp; will check-in with next label, as a release for only integration pieces that were not checked-in will take place on August 2, 2008</strong></p>\r\n<p>User reported being able to view application even after being removed due to lapse in training.&nbsp; Study number is 589-94 and user is Jennifer Klakmis.&nbsp; I remoted to her computer to see and she did have access.&nbsp; I'm assuming this is a read/edit policy issue for application project type since she was removed, but now is being added via a personnel change, which has not been approved.&nbsp; She could also still see it last week...week of May 13th&nbsp;prior to personnel modification being started.</p>\r\n<p>6/18/2008 BW:</p>\r\n<p>Confirmed this is a security issue on the Application Project Type Read policy:</p>\r\n<p>Currently the custom search used to allow read access includes Removed Study Team Member.&nbsp; They can only read and cannot create new sub-projects.&nbsp; To fix this, the custom search PI and Staff_Application_Security needs to have the or clause removed that includes Removed Study Team Members contains logged on user.</p>",
"projects.*.id": ""
}
]
}


not sure why the grid wont load the data

adeelmahmood
14 Aug 2012, 10:01 AM
never mind problem was in one of the fields that had a dot in it .. took that out and data is loading fine